Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have seen that there are a lot of threads about this problem.

I had Windows 8 installed on my series 3 samsung i5 computer and I tried to install ubuntu 13.04.

This is what I did:

Because of the secure boot I can't install ubuntu from the dvd. So I went in the bios and disabled secure boot and enabled ''CSM''. I went out of the bios and windows 8 couldn't boot more. So I follow a guide on this thread ( Installing on a Pre-Installed Windows 8 System (UEFI Supported) ) and on ubuntu I tried to repair the boot by inserting this code in the terminal:

sudo add-apt-repository ppa:yannubuntu/boot-repair 
sudo apt-get update
sudo apt-get install boot-repair

Then I ran boot-repair and I follow all the steps. Then I reboot the sistem and saw the black screen that says:

error: file '/boot/grub/i386-pc/normal mod' not found
grub rescure>

Now I saw a lot of guides about this problem but I can't understand how to reistall ubuntu trough the live dvd that I used to install it the first time... I put it in the computer but nothing appears.. so what should I do now? I'm a noob on ubuntu and I have read all the things about this grub 2 install and know where the problem comes from but how to start the dvd??

share|improve this question
    
Did you run Boot-Repair to convert from BIOS/CSM install to UEFI install. And then are you booting in UEFI mode with either secure boot off or with secure boot on. YOu probably can only boot Ubuntu with secure boot off as you have to boot the Boot-Repair with secure boot on to get the signed shim and kernels that will work with secure boot installed. –  oldfred Jul 28 '13 at 22:15
    
I dont know if it is of or on.. i think it is because off this boot repair.. i did this boot repair because i want to boot also windows 8 and not only Ubuntu. but i don't know i follow thw guide on the link that i had atteached in the before question. –  user179295 Jul 29 '13 at 0:13

1 Answer 1

Your GRUB configuration is messed up. Because it appears that Boot Repair created this problem, it's unlikely that it will be able to fix it, except perhaps by selecting advanced options to undo some of its changes. Basically, though, repairing GRUB at this point requires a fair amount of expertise.

A simpler approach might be the following:

  1. On another computer, download the USB flash drive or CD-R image of my rEFInd boot manager.
  2. Prepare the USB flash drive or CD-R with rEFInd.
  3. Use the USB flash drive or CD-R to boot your troubled computer. (You may need to select a firmware option to boot from the external medium. Unfortunately, these options vary greatly from one computer to another.) With any luck, rEFInd will show options to boot both Windows and Linux. (There may be multiple Linux options.)
  4. Try both the Windows and Linux options.
  5. If both Windows and Linux boot, install the rEFInd .deb package in Ubuntu.

If you have problems with rEFInd, then your recovery will require more diagnosis. To that end, you should run the Boot Info Script and post a link to the RESULTS.txt file that it generates. That script's output will provide details of your configuration that should help in getting things working.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.