Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can i uninstall GCC 4.7.3 and install GCC 4.5? I want to install 4.5 because otherwise my BF 1942 wont open with wine.

share|improve this question
1  
Welcome to Ask Ubuntu! Please expand your question by including details about what Wine needs to run BF1942. Why do you believe having GCC 4.5 installed will help? Can you give a link to a source for this? Note that having GCC 4.5 installed will not cause the version of Wine you have installed to be built with GCC 4.5, nor will it generally cause the version of Wine you have installed to use different libraries (though that is possible). This problem probably can be solved but we'll most likely need more information to give a comprehensive answer. Also, what version of Ubuntu do you use? –  Eliah Kagan Jul 28 '13 at 20:11

1 Answer 1

You should be able to install it and it will update the older version with the newer files.

If you installed the programme with sudo apt-get install <programme> you could use sudo apt-get purge <programme>

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.