Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It worked a few days ago and now it throws me this error, while I click on show calendar:

Traceback (most recent call last):

  File "/usr/share/calendar-indicator/calendarindicator.py", line 361, in menu_show_calendar_response
    cd = CalendarWindow(self.googlecalendar,calendar_id=self.calendar_id)
  File "/usr/share/calendar-indicator/calendarwindow.py", line 233, in __init__
    self.set_date()
  File "/usr/share/calendar-indicator/calendarwindow.py", line 272, in set_date
    print(aevent['summary'])
KeyError: 'summary'

I have ubuntu 13.04 OS

Does anyone know what's wrong and how to fix it?

share|improve this question

closed as off-topic by Braiam, Alaa Ali, guntbert, Eric Carvalho, Radu Rădeanu Sep 28 '13 at 19:58

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, Alaa Ali, guntbert, Eric Carvalho, Radu Rădeanu
If this question can be reworded to fit the rules in the help center, please edit the question.

1  
I believe you should report this as a bug. –  Braiam Sep 28 '13 at 2:14

2 Answers 2

you can solve your issue with re-installing the application.open your terminal and type as

sudo apt-get install --reinstall calendar-indicator
share|improve this answer
    
I tried to uninstall and install it again but it didn't work, but now, and I don't now how, it started to work. I think it has something to do with the graphic's drivers because when I came back to the Nouveau's open source drivers it started to work again. But I can't explain why –  Alekhios Aug 11 '13 at 23:31
    
good news then , enjoy using it. –  AgentCool Aug 12 '13 at 13:08

Have seen a similar issue when trying to switch to a calendar shared by another google account with mine:

Traceback (most recent call last):
  File "/usr/share/calendar-indicator/calendarindicator.py", line 355, in menu_preferences_response
    self.update_menu()      
  File "/usr/share/calendar-indicator/calendarindicator.py", line 233, in update_menu
    self.menu_events[i].set_label(event.get_start_date_string()+' - '+short_msg(event['summary']))
KeyError: 'summary'

only solution is to never select that calendar or 'all calendars' in preferences.. To get it working again, I just deleted everything in ~/.config/calendar-indicator and started over.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.