Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have the following problem:

I have 2 hard disks on my pc. My first disk is a 500 GB hd and I have got Ubuntu 12.04 installed a long time now. My second disk is a 2TB disk in which I just installed windows 7 x64.

Everything was just fine, but 3 days ago I installed SAPPHIRE HD 7770 GHz Edition OC 1GB GDDR5 in my system. GRUB menu (which I tweaked through this post : I can't get grub menu to show up during boot ) after the installation of the new graphics card boots normally into Windows but it will not boot under any circumnstances on my Ubuntu 12.04 ('Check signal cable message') . I even tried with a live cd it just went to black screen again 5 seconds after it had started.

I have got some serious projects on my Ubuntu since it is the primary OS that I am using so a little help would be much appreciated.

My system: ASUS motherboard 2 hard drives just I mentioned, my new graphics card SAPPHIRE HD 7770 GHz Edition OC 1GB GDDR5, RAM: 2 X 4 GB , processor : AMD A4 3400 CPU with embedded graphics card(that I am not using anymore).

PS: Note that it worked well up until 4 days ago, without the new graphics card.

Please help me if you can. Thanks in advance.

share|improve this question
try recovery mode and upgrade graphic drivers? – Private Jul 28 '13 at 15:11
Have you tried the following… – SimplySimon Jul 28 '13 at 15:12
Thanks for your anwsers. I have just removed graphics card, and have succesfully entered with my onboard graphics card into Ubuntu 12.04 . Simon I now think that it has nothing to do with the GRUB menu and it has to do more on the graphics card as the first guy pointed out. Maybe the graphic drivers is the problem. I ll try to get into recovery mode and post my results. Tell me what you think on this, if you can Simon. – George Kourouleas Jul 28 '13 at 15:23
@GeorgeKourouleas Try installing Resolution Switcher from the Ubuntu Software Center, and then check if you can change to your optimal screen resolution of 1920x1200 from the Resolution Switcher menu entry for Configure Display Settings. – karel Jul 29 '13 at 22:12
up vote 0 down vote accepted

It sometimes happens when you buy a new graphics card that has an AMD GPU that the graphics card is so new that the latest version of the AMD Catalyst graphics driver for Linux doesn't work on Ubuntu. Sometimes it takes AMD a few months for their latest Catalyst graphics driver for Linux to catch up with the newest models of graphics cards.

There are instructions for how to install the latest AMD Catalyst graphics driver in the answers to the question: What is the correct way to install ATI Catalyst Video Drivers (fglrx)?.

Sometimes however you can simply install the fglrx package from the Ubuntu Software Center, and it will work just fine, even with one of the newest models of graphics cards that has an AMD GPU. The description for fglrx in the Ubuntu Software Center is: "Video driver for the AMD Radeon and FireGL graphics accelerators".

share|improve this answer
Thanks for your anwser karel. Worked just fine. I have one little problem though. In AMD Catalyst Center on Windows there is an option saying 'handling of AVG monitors'. In there, you can change the resolution from 1600 * 1200 to 1920 * 1200 or whatever you want. I am stack on 1600 * 1200 here although the optimal for my screen is 1920 * 1200. Does it happen to know everything to fix that? Thanks for you anwser yet another time. – George Kourouleas Jul 28 '13 at 16:43
Ok. Waiting for your anwser as soon as you can & want. Thank you. – George Kourouleas Jul 28 '13 at 16:49
@user204610 I prepared my answer to your comment as a separate document so that I could include a screenshot that illustrates what to do. I uploaded the document, and you can view it at this link. – karel Jul 29 '13 at 11:45
Thanks for your answer karel. But I could figure out from the start this option since I have a lot of experience in catalyst center on ubuntu. My problem is though, that as you state in your picture, the optimal is 1600*XXXX, and mine is 1600*1200, but both my screen and my graphics card support a resolution up to 1920*1200 and I cannot get that resolution no matter what. In Windows there is an option 'VGA monitor' that overrides that and lets you choose higher resolutions. On ubuntu that is not the scenario unfortunately. Does it happen to know a way to increase the resolution? Thanks agian. – George Kourouleas Jul 29 '13 at 12:58
If you visit the AMD Linux Community wiki you will see that the latest supported hardware for the AMD Catalyst driver is Radeon HD 6990 and your graphics card is HD 7770. It would be interesting to see if the AMD driver compatible with HD 7770 solves your problem when it is released. – karel Jul 29 '13 at 14:10

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.