Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Starting apparmor on a Ubuntu Lucid Lynx gives the following:

user@host:~$ sudo /etc/init.d/apparmor start
 * Starting AppArmor profiles
 * AppArmor not available as kernel LSM.
   ...fail!

Googling a bit, I found the following bug report - marked as fixed -:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/375422

Which seems to be my exact case. My kernel is 2.6.32-21-generic. Any idea on how to solve the issue?

share|improve this question

closed as off topic by belacqua, James May 23 '12 at 17:18

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. – coversnail Apr 16 '12 at 12:15

The only thing I can think of is to get a Launchpad account if you do not already have one, then go to the bug report. Mark yourself as affected by that bug and post another comment there with your specs.

Alternatively, you could try filing your case as a new bug, but it may end up being marked as a duplicate in that case.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.