Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My problem is as follows: I have recently installed a fresh copy of Ubuntu 12.04 LTS, and upon booting, the DisplayPort monitor loses signal immediatedly after the Ubuntu splash screen.

A brief history of what I've done and tried:

  1. I installed Ubuntu, allowing the OS to download updates while installing, and my monitor lost signal immediately after splash the first time I booted.
  2. I re-installed Ubuntu not allowing the OS to download updates, and my computer booted through splash screen successfully.
  3. I updated the nVidia drivers, selecting "nvidia-current" and then rebooted. I was again met with no signal immediately after splash.
  4. I tried editing the boot command in grub by adding "nomodeset", disabling splash, etc. and experienced no change; the monitor still received no signal.
  5. I tried various versions of the nvidia drivers and experienced no change.
  6. I FINALLY tried removing my DisplayPort cable, instead connecting the monitor via HDMI. I have signal just fine!

Once I log in with HDMI connected, I can swap the cables for DisplayPort and I receive signal just fine as well. I just can't boot with DisplayPort connected.

Some background about my relevant (and maybe some irrelevant) hardware:

  • Motherboard: Asus Maximus V Gene
  • GPU: EVGA GeForce 660 Ti
  • Monitor: Dell S2340T

I'm still relatively inexperienced with Linux, so I'm not sure what to try to get DisplayPort working through boot. Any suggestions would be much appreciated!

Brian

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.