Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I try to run a sudo gedit command as instructed in Step 4 of this answer, my terminal puts out:

(gedit:7549): IBUS-WARNING **: The owner of /home/jared/.config/ibus/bus is not root!

How do I get out of this situation?

share|improve this question

4 Answers 4

You should always use gksudo instead of sudo to launch graphical applications otherwise the environmental variables aren't set up correctly.

In your example ibus is looking at the files in your users home directory instead of roots home directory as it should be doing.

share|improve this answer

yeah, as Cheesemill say, u should use gksudo to launch graphical like gedit. to install it, simply type this command in terminal:

sudo apt-get install gksu

I read some topics that have same problem to you (and so I am). Some men say just del rm -r /home/<user-name>/.config/ibus/bus or rm -r /home/<user-name>/.config/ibus/ and then launch iBus again.

Some men say remove (or purge) ibus and then re-install it.

Some men say try to chown the bus folder

...

I tried it out but it didn't work, or temporary worked until I rebooted my PC.

May this is a little bug with iBus on Ubuntu 13.04, because this bug didn't available on Ubuntu 12.04.

I hope iBus will have a little update in the future.

thx for reading my first comment on askUbuntu.

share|improve this answer

Install OpenJDK from the Ubuntu Software Center and you will have no problems when installing, you can also try the following:

sudo add-apt-repository ppa:webupd8team/java

sudo apt-get update

sudo apt-get install oracle-java8-installer

This will install the latest Java 8 version on Ubuntu, JRE and JDK.

Set the environment variable with:

sudo apt-get install oracle-java8-set-default
share|improve this answer

Do this on a terminal:

michele@Zeus:~/.config/ibus$ sudo gedit /etc/bluetooth/main.conf

(gedit:3940): IBUS-WARNING **: The owner of /home/michele/.config/ibus/bus is not root!

michele@Zeus:~/.config/ibus$ ll
totale 12

drwx------  3 michele michele 4096 dic 29 18:11 ./

drwx------ 26 michele michele 4096 gen  2 12:25 ../

**drwx------  2 michele michele 4096 gen  5 13:19 bus/**

michele@Zeus:~/.config/ibus$ rm -R bus/

michele@Zeus:~/.config/ibus$ sudo gedit /etc/bluetooth/main.conf

and now!!!

michele@Zeus:~/.config/ibus$ ll

totale 12

drwx------  3 michele michele 4096 gen  5 13:35 ./

drwx------ 26 michele michele 4096 gen  2 12:25 ../

**drwx------  2 root    root    4096 gen  5 13:35 bus/**
share|improve this answer
    
Welcome to Ask Ubuntu! While we are glad you are trying to help, this question could use some explanation as to what the asker is doing with your answer, and maybe some links to where you got this (if any) –  RPi Awesomeness Jan 5 at 16:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.