Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So, after trying to setup Bumblebee, I did mess up a lot of my Ubuntu installations, including installing and taking down Nvidia drivers - resolving mirrored and flipped text issues, and well - I managed to do all that, except that now icons and most of GUI elements are just black and white.

I would guess it's related to Linux-headers - as the problem appeared somewhere in that timespan.

Also it could be with 3d acceleration related things? I'm not sure, my first week on Linux.

So - now it looks like this.

enter image description here

I've tried reinstalling both compiz / unity following instructions around. Tried fallback to Gnome (no idea), didn't help either. Any solutions?

Loading CCSM from Terminal gives this:

Gtk-WARNING : Unable to locate theme engine in module_path: "hcengine",

-- lshw -c video information

   *-display               
   description: VGA compatible controller
   product: GF108M [GeForce GT 540M]
   vendor: NVIDIA Corporation
   physical id: 0
   bus info: pci@0000:01:00.0
   version: a1
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
   configuration: driver=nvidia latency=0

--

   *-display
   description: VGA compatible controller
   product: Core Processor Integrated Graphics Controller
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 02
   width: 64 bits
   clock: 33MHz
   capabilities: msi pm vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:43 memory:d1400000-d17fffff memory:c0000000-cfffffff ioport:4050(size=8)

-- unity_support_test

OpenGL vendor string:   Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile 
OpenGL version string:  2.1 Mesa 9.1.3

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes
share|improve this question

1 Answer 1

First of all, remove all your Nvidia drivers and bumblebee:

sudo apt-get purge nvidia*
sudo apt-get purge bumblebee*

Then install the current Nvidia drivers:

sudo apt-get install nvidia-current
share|improve this answer
    
did both already would rather not install the nvidia-current, since it did break unity/compiz in first place all I have now from nvidia is the nvidia-updates –  Roberts Lazda Jul 26 '13 at 23:51
    
I posted this as an answer because the source of the problem is probably caused by conflicting drivers. I've had a similar problem and this was the solution for me. –  Joren Jul 26 '13 at 23:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.