Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A couple of months ago I installed Postgesql 9.1 and Postgis 2.0 on my Ubuntu 12.04 server. Now I can't do any apt-get upgrades or installs because of this installation with broken libgdal1 dependencies. I've tried sudo apt-get autoremove and sudo apt-get install -f like it suggests but it won't work and just gives me the following errors:

dpkg: dependency problems prevent configuration of postgis: postgis depends on libgdal1 (>= 1.9.0); however: Package libgdal1 is not installed. 
    postgis depends on postgresql-9.1-postgis; however: Package postgresql-9.1-postgis is not installed. 
dpkg: error processing postgis (--configure): dependency problems - leaving unconfigured 
No apport report written because MaxReports is reached already 
Errors were encountered while processing: postgis 
E: Sub-process /usr/bin/dpkg returned an error code (1)

I feel like I'll need to backup and restore my database just to get apt-get working again which is absolute craziness. These are the times when I really miss working with Windows installations. Any help/suggestions would be greatly appreciated.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.