Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just installed 12.04 in a dual boot with Vista via a LiveUSB. When I booted to the LiveUSB wired networking worked out of the box, and wireless networking didn't work. Now that I've installed 12.04 on a partition on the harddrive I can't get wired or wireless networking to work.

Any suggestions as how to how I should go about fixing this? The output of sudo lshw -C network is:

  *-network
       description: Network controller
       product: BCM4311 802.11b/g WLAN
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:0c:00.0
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=wl latency=0
       resources: irq:17 memory:fe8fc000-fe8fffff
  *-network UNCLAIMED
       description: Ethernet controller
       product: BCM4401-B0 100Base-TX
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 02
       width: 32 bits
       clock: 33MHz
       capabilities: pm cap_list
       configuration: latency=64
       resources: memory:fe5fe000-fe5fffff
share|improve this question
    
That's very unfortunate to have both wireless and wired networking not working. Do you have an updated 12.04.2 (note the .2!) image? Did you also try 13.04? –  gertvdijk Jul 26 '13 at 16:07
    
It is indeed, and it seems strange that the wired networking worked on the LiveUSB but not with the full install! Yes, I do have 12.04.2. I'd rather stick with that if possible, as it's the LTS. Is there now way I can download a driver and copy it accross on a flash drive? –  Jim Jul 26 '13 at 16:45
    
Listen to @chili555 :) –  gertvdijk Jul 26 '13 at 23:10

1 Answer 1

up vote 2 down vote accepted

Additional Drivers sometimes offers to install the wrong drivers! Please open a terminal and do:

sudo apt-get remove --purge bcmwl-kernel-source
sudo modprobe b44

Now your ethernet should be working. Hook it up and do:

sudo apt-get install linux-firmware-nonfree

Upon reboot, both should be working fine.

share|improve this answer
    
After a couple of attempts that worked perfectly, thank you so much! –  Jim Jul 27 '13 at 14:13
    
I am experiencing the same problem but my wired connection is working and wireless is not working. I tried the above commands, restarted the system but wifi still does not work. –  Sachin Jan 6 at 10:24
    
@Sachin I suggest you start your own new question and provide the wireless card details from: lspci -nn | grep 0280 –  chili555 Jan 6 at 14:34
    
Thanks for the response @chili555 but I had fixed the issue –  Sachin Jan 7 at 16:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.