Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am getting my new laptop going and went to install the latest oracle JDK 7u25. I followed the instructions on this site to do it.

Afterwards when I type java --version in the terminal I get the error:

Error: Could not create the Java Virtual Machine

I tried reinstalling it via a different method but the error wont go away. I am running Ubuntu 12.04 64bit.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I would advise you to use the webupd8 method instead since that way you just need to add a PPA and then you can just install jdk through apt and get updates.

share|improve this answer
    
im sorry but this didnt fix the problem –  John Jul 26 '13 at 13:36
    
Did you first remove your first installation ? –  Benoît Legat Jul 26 '13 at 20:14
    
yes, at this point I reinstalled Ubuntu, i was working on a fresh install anyway. –  John Jul 26 '13 at 20:26
    
Well then if the PPA doesn't work I would advise you do contact webupd8 directly telling him the problem so that he can fix it for you and for him –  Benoît Legat Jul 28 '13 at 12:00
    
Oh, you mean you did a fresh install and now it is working ? –  Benoît Legat Jul 28 '13 at 12:07

Use:

java -version

instead of:

java --version

However, it's still not excusable that such cryptic error message is produced for the extra dash sign. Especially because java is not an amateur software but a kind of the very best software.

share|improve this answer
    
Wao... helped...... –  Umair Ayub May 12 at 10:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.