Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I installed Ubuntu (switch from Fedora) two days ago and I'm almost productive again except for one thing:

When I connect to my work's VPN, Network Manager doesn't pick up the nameservers like Fedora did. When I connect I can ping the IP addresses directly:

$ ping source.my-company.com
> ping: unknown host source.my-company.com
$ ping 123.45.67.890
> 64 bytes from 123.45.67.890: icmp_req=2 ttl=64 time=67.8 ms
> ...

What's more irritating is that I can easily ping the nameservers too. My network guy wants me to manually edit resolv.conf, but that's not sustainable since I regularly switch between 3 VPNs. (Another source of irritation for another day: Fedora allowed me to connect to multiple VPNs, why won't Ubuntu?)

My question is how do I begin to debug this? I'm unfamiliar with DNS and Networking in general, and using new tools makes it harder to figure out.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Edit your VPN connection, click IPv4 Settings tab, select Automatic (VPN) addresses only in Method dropdown and type your company's DNS servers and domain in the boxes at the bottom.

enter image description here

share|improve this answer
    
Actually just figured out how to fix the problem, but this was only half of the problem. I commented out dns=dnsmasq in the NetworkManager.conf and that fixed it. –  Christopher Pfohl Jul 26 '13 at 14:27
    
Unfortunately this is a bummer of an issue: on Fedora NetworkManager automatically found the dns servers and domains. Is there any way to get that functionality in Ubuntu? –  Christopher Pfohl Jul 26 '13 at 14:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.