Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an issue with an Ubuntu 12.04 LTS (updated) server.

For reasons too long to detail, it has got one eth0 interface assigned to 192.168.1.9 and one wlan0 interface assigned to 192.168.1.10. Both MUST work since boot time.

I also installed (I need of monitoring software) Lubuntu desktop-core and removed Network manager (rebooted) and using wpa_supplicant + /etc/network/interface hardcoded configuration and fixed IPs.

Everything works like a charm. From the Lubuntu desktop I can browse the internet from eth0, I can unplug it and browse internet through wlan0 edit: I must ifdown eth0 for that to happen but even then, I can use the server and browse internet with it but not contact it from other computers

I can ping and ssh this server eth0 from another computer just fine. However - and this is my issue - I can neither ping nor ssh to this server wlan0.

I thought it was some routing issue, but even commenting out the eth0 stanza in interfaces I still cannot access the server from the outside. Of course if I go on the server and try pinging (both from console and desktop) or navigating internet, it works perfectly.

Do you have any idea about where I could start look after?

Once I return to work I'll post my interfaces file, it's pretty standard and no DHCP involved (both interfaces have static IP as described above).


Details on the configs that have been asked to provide:

ifconfig:

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:18 errors:0 dropped:0 overruns:0 frame:0
          TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1613 (1.6 KB)  TX bytes:1613 (1.6 KB)

wlan0     Link encap:Ethernet  HWaddr 00:c0:49:fc:db:3f  
          inet addr:192.168.1.10  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::2c0:49ff:fefc:db3f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16376 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3337 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:4675792 (4.6 MB)  TX bytes:543084 (543.0 KB)

When I enable the eth0 with ifup, I get this stanza added:

eth0      Link encap:Ethernet  HWaddr 00:0e:a6:aa:5b:be  
          inet addr:192.168.1.9  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

route -n:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    100    0        0 wlan0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0

if I disable eth0 of course the relevant line goes away.

IPTables shows clean, I am using UFW and I have disabled it at the moment as well

iptables -L -nv:

Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination         
share|improve this question
    
Please post the output of ifconfig, route -n and iptables -L -nv. –  Eric Carvalho Jul 26 '13 at 12:24
    
Sure, 30 mins and I am back in the office. In the meanwhile I wanted to add that the wlan0 will be the main interface to use, the eth0 will be only connected in case of issues. That is wlan0 has to be primary and work since boot time. –  Dario Fumagalli Jul 26 '13 at 12:52
    
Ok I updated the OP with the requested data –  Dario Fumagalli Jul 26 '13 at 14:32
    
Pretty please help me get out of this enpasse. –  Dario Fumagalli Jul 27 '13 at 0:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.