Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use wget in a cron job to download my google calendar. I know it was still working last week. Today I noticed it doesn't anymore. wget won't accept google's certificate:

$ wget --debug  https://www.google.com/calendar/ical/<private-id>/basic.ics
> DEBUG output created by Wget 1.12 on linux-gnu.

--2013-07-26 12:36:31--  https://www.google.com/
Resolving www.google.com... 109.105.109.234, 109.105.109.223, 109.105.109.208, ...
Caching www.google.com => 109.105.109.234 109.105.109.223 109.105.109.208 109.105.109.249 109.105.109.229 109.105.109.219 109.105.109.245 109.105.109.227 109.105.109.240 109.105.109.230 109.105.109.241 109.105.109.212 109.105.109.251 109.105.109.216 109.105.109.238 109.105.109.218 2a00:1450:400f:803::1012
Connecting to www.google.com|109.105.109.234|:443... connected.
Created socket 3.
Releasing 0x09046cf8 (new refcount 1).
Initiating SSL handshake.
Handshake successful; connected socket 3 to SSL handle 0x09047090
certificate:
  subject: /C=US/ST=California/O=Google Inc/CN=google.com
  issuer:  /C=US/O=Google Inc/CN=Google Internet Authority
ERROR: certificate common name `google.com' doesn't match requested host name `www.google.com'.
To connect to www.google.com insecurely, use `--no-check-certificate'.
Closed 3/SSL 0x09047090

So wget doesn't want to match google.com with www.google.com. Which is weird. The certificates seem to be fine. curl is working:

curl -v https://www.google.com/calendar/ical/<private-id>/basic.ics
* About to connect() to www.google.com port 443 (#0)
*   Trying 109.105.109.219... connected
* Connected to www.google.com (109.105.109.219) port 443 (#0)
* successfully set certificate verify locations:
*   CAfile: none
  CApath: /etc/ssl/certs
* SSLv3, TLS handshake, Client hello (1):
* SSLv3, TLS handshake, Server hello (2):
* SSLv3, TLS handshake, CERT (11):
* SSLv3, TLS handshake, Server key exchange (12):
* SSLv3, TLS handshake, Server finished (14):
* SSLv3, TLS handshake, Client key exchange (16):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSL connection using ECDHE-RSA-RC4-SHA
* Server certificate:
*    subject: C=US; ST=California; L=Mountain View; O=Google Inc; CN=www.google.com
*    start date: 2013-07-12 08:56:36 GMT
*    expire date: 2013-10-31 23:59:59 GMT
*    subjectAltName: www.google.com matched
*    issuer: C=US; O=Google Inc; CN=Google Internet Authority
*    SSL certificate verify ok.
> GET /calendar/ical/<private-id>/basic.ics HTTP/1.1
> User-Agent: curl/7.21.6 (i686-pc-linux-gnu) libcurl/7.21.6 OpenSSL/1.0.0e zlib/1.2.3.4 libidn/1.22 librtmp/2.3
> Host: www.google.com
> Accept: */*
> 
< HTTP/1.1 200 OK
< Expires: Fri, 01 Jan 1990 00:00:00 GMT
< Date: Fri, 26 Jul 2013 10:42:18 GMT
< Content-Type: text/calendar; charset=UTF-8
< Cache-Control: no-cache, no-store, max-age=0, must-revalidate
< Pragma: no-cache
< X-Content-Type-Options: nosniff
< X-Frame-Options: SAMEORIGIN
< X-XSS-Protection: 1; mode=block
< Server: GSE
< Transfer-Encoding: chunked
< 
...

It's not terrible, I can just use curl instead. But still - why isn't it working?

My system is:

$ wget --version
> GNU Wget 1.12 built on linux-gnu.

+digest +ipv6 +nls +ntlm +opie +md5/openssl +https -gnutls +openssl 
-iri 

Wgetrc: 
    /etc/wgetrc (system)
Locale: /usr/share/locale 
Compile: gcc -DHAVE_CONFIG_H -DSYSTEM_WGETRC="/etc/wgetrc" 
    -DLOCALEDIR="/usr/share/locale" -I. -I../lib -g -O2 -DNO_SSLv2 
    -D_FILE_OFFSET_BITS=64 -O2 -g -Wall 
Link: gcc -g -O2 -DNO_SSLv2 -D_FILE_OFFSET_BITS=64 -O2 -g -Wall 
    -Wl,-Bsymbolic-functions /usr/lib/libssl.so /usr/lib/libcrypto.so 
    -ldl -lrt ftp-opie.o openssl.o http-ntlm.o gen-md5.o 
    ../lib/libgnu.a 

Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later
<http://www.gnu.org/licenses/gpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Originally written by Hrvoje Niksic <hniksic@xemacs.org>.
Currently maintained by Micah Cowan <micah@cowan.name>.
Please send bug reports and questions to <bug-wget@gnu.org>.


$ uname -a
> Linux andrEee 3.0.0-32-generic #51-Ubuntu SMP Thu Mar 21 15:51:26 UTC 2013 i686 i686 i386 GNU/Linux

$ lsb_release -a
> No LSB modules are available.
  Distributor ID:   Ubuntu
  Description:  Ubuntu 11.10
  Release:  11.10
  Codename: oneiric
share|improve this question

closed as off-topic by Seth, Eric Carvalho, Thomas W., Kevin Bowen, guntbert Aug 25 '13 at 20:08

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Seth, Eric Carvalho, Thomas W., Kevin Bowen
If this question can be reworded to fit the rules in the help center, please edit the question.

2  
this looks related bugs.launchpad.net/ubuntu/+source/wget/+bug/733888 –  Shutupsquare Jul 26 '13 at 11:19
    
I have 1.12. You are right, this seems to be fixed in 1.14. –  ahilsend Jul 26 '13 at 11:25
    
Oneric is no longer receiving updates can you upgrade? –  Shutupsquare Jul 26 '13 at 11:25
    
I could update - maybe I will. Than that's solved, thanks! –  ahilsend Jul 26 '13 at 11:29
    
Cool ill add it to an answer then. –  Shutupsquare Jul 26 '13 at 11:30

1 Answer 1

up vote 2 down vote accepted

This is a known bug in wget 1.12.

As you are running an unsupported version of ubuntu the best course of action would be to upgrade to a supported version . wget 1.14 is the latest version in ubuntu and has fixed this bug.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.