Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new to Ubuntu 13.04. I am trying to do a full backup to my USB and I have used GParted to create a partition on my USB and formatted it as ext4. It still has permission denied errors. I get this message:

Permission denied when trying to create ‘/media/stacyjane/ubuntu backup/duplicity-full.20130726T043854Z.vol1.difftar.gpg
share|improve this question
    
Welcome to Ask Ubuntu! Please edit your question and add commands you used. –  Danatela Jul 26 '13 at 8:12

1 Answer 1

You need to set ownership & permissions.

https://help.ubuntu.com/community/FilePermissions

If mounted at /media/stacyjane

sudo chmod -R a+rwX,o-w /media/stacyjane
sudo chown $USER:$USER /media/stacyjane

Note that the -R is recursion and everything is changed, do NOT run on any system partitions. All directories will be 775. All files will be 664 except those that were set as executable to begin with.

The -R parameter is recursive, so it will apply to all lower directories & files, but do not use on any system partition, just data.

see also

man chmod
man chown
share|improve this answer
    
hi oldfred..thank you so much for the commands. I copied your commands, and it did change the permissions on the usb to create and delete, but when I tried to run the first full backup, now I am getting: Backup location ‘/tmp/duplicity-wc_Bzd-tempdir/mktemp-_0VJzA-2’ does not exist. –  user178487 Jul 27 '13 at 5:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.