Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had a problem mounting an NTFS partition using pysdm that's discussed here -

can't mount ntfs partition without root access

I resolved it by the fstab edits suggested. However, I now get an "error mount 0 - skip or fix now?" (paraphrased from memory) message on startup. "Skip" boots normally and everything mounts correctly. I have found these messages in the kernel log -

26/07/13 11:27:25   EXT4-fs (sda6)  warning: maximal mount count reached, running e2fsck is recommended
26/07/13 11:27:25   EXT4-fs (sda6)  mounted filesystem with ordered data mode. Opts: (null)

This is my current /etc/fstab -

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc                                       /proc             proc  nodev,noexec,nosuid                                                           0  0  
# / was on /dev/sda8 during installation
UUID=[id###]  /                 ext4  errors=remount-ro                                                             0  1  
# swap was on /dev/sda7 during installation
UUID=[id###]  none              swap  sw                                                                            0  0  
/dev/sda5                                  /media/data       ntfs   
nls=iso8859-1,rw,umask=000,user  0  0
/dev/sda6                                  /media/ext4-data  ext4  defaults                                                                      0  0  

This is the only part I manually edited -

nls=iso8859-1,rw,umask=000,user 0 0

This line is residue from pysdm -

/dev/sda5                                  /media/data       ntfs 

Did I cause this error or is there some configurable mount setting I am unaware of?

EDIT: This is screencap of fstab showing the split line for sda5 -

http://oi42.tinypic.com/6nywcx.jpg

share|improve this question
    
why you don't use ntfs3g ? –  Rodislav Jul 26 '13 at 8:46
add comment

1 Answer 1

I cannot recommend using pysdm as it has not been maintained for ages. It still uses devices not UUID and does not have good parameters.

Your fstab does not look at all correct. Is it as posted? Did you edit out UUID and parameters at ends of every line?

The nls.. line is not a separate line but part of the sda5 ntfs mount line.

For ntfs UUID shown is example only see below to find yours:

UUID=DA9056C19056A3B3 /media/data ntfs defaults,nls=utf8,umask=000,uid=1000,windows_names 0 0

Window_names prevents the use of invalid windows characters: (which are the nine characters ” * / : < > ? \ | and those whose code is less than 0×20) uid=1000 should fix the trash problems as well:

for ext4

UUID=076426af-cbc5-4966-8cd4-af0f5c879646 /media/ext4-data ext4 defaults,noatime 0 2

find UUIDs

sudo blkid -c /dev/null -o list

And when you are done editing fstab and saving it run the following command to test for errors and mount the partitions without requiring a reboot. You will know before you reboot if something is amiss. Make sure you have partition unmounted if previously mounted:

sudo mount -a

More info and details on format of typical fstab entry.

Understanding fstab

http://www.psychocats.net/ubuntu/mountlinux

https://help.ubuntu.com/community/Mount/

https://help.ubuntu.com/community/FilePermissions

https://help.ubuntu.com/community/Fstab

share|improve this answer
    
"I cannot recommend using pysdm as it has not been maintained for ages. It still uses devices not UUID and does not have good parameters." -- yes, I found out the hard way. What mounted fine manually broke after pysdm, hence my visit here. "Your fstab does not look at all correct. Is it as posted? Did you edit out UUID and parameters at ends of every line?" -- it is precisely as is, I just removed the my UUIDs for ext4 and swap to post here. Thanks, I'll do some reading. –  user178158 Jul 26 '13 at 5:24
    
What are the kernel messages referring to e2fsck? I found some posts mentioning it has "repair" options. –  user178158 Jul 26 '13 at 5:25
    
This is the exact message I get - forums.linuxmint.com/viewtopic.php?f=49&t=60594 - and the suggested fix mentions a split line problem. The sda5 entry does look like it's on 2 lines. The fix mentions a "continuation \" between the two. Is this possibly it? Fstab works perfectly fine when I skip the error otherwise. –  user178158 Jul 26 '13 at 8:29
    
Added screencap to main post. –  user178158 Jul 26 '13 at 8:40
    
I have not seen continuation as everything is usually one line. try making it one line. Also your other entries do not show the two numbers that are at the end of the line? noexec & nosuid, see also man fstab –  oldfred Jul 26 '13 at 17:10
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.