Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Recently, I decided to use Ubuntu as a work related OS. I was impressed with its overall performance and its simplicity (yes, Ubuntu is simple to me). Everything was working great until I found out that my sound card won't output any audio through the laptop speakers. If I use headphones, it works fine, but without them, no audio.

I am using an HP dv7 Quad Core edition (2013). I have configured the speakers, tried maximizing the volume settings, still with no speaker output.

All that it reads on the audio device selection panel is "Speakers; Built-in Audio"

My question is, is there a way to fix this issue? If not, when will it be available? Are there any drivers that should be available? For proprietary drivers (Additional Drivers tab), there aren't any drivers available, the list is just blank.

Here is a list of running devices if helpful.

Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 138a:0018 Validity Sensors, Inc. 
Bus 001 Device 004: ID 0bda:58d8 Realtek Semiconductor Corp. 
share|improve this question

2 Answers 2

I own a hp-dv7-7102ea which I believe is a very similar (but older) model so hopefully these instructions (which worked for me on linuxmint 15) should work.

how to make the speakers work

a system-wide equaliser if you still want to try and improve the sound even more :)

Also type "alsamixer" into the terminal to adjust the speaker and the subwoofer volumes.

Hope this helps! (Ps. read the comments on the FIRST link as they provide more detailed info which makes sure the headphone jack still works properly)

with thanks to CalcProgrammer1

share|improve this answer

Solution is simple than you think. Just install alsa-tools-gui as shown below.

sudo apt-get install alsa-tools-gui

Then look for HDAJackRetask application through Unity Desktop search, if you are using Gnome, it should be under Sound & Video Menu. Open the app and use the settings as show on the screen shot below.

enter image description here

Then click on the Apply now button on the right panel.

Now test the sound by playing an audio file, remember to increase or reduce volume for changes to take effect. If your are satisfied "Install boot override"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.