Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

NOTE: While working through my issue and documenting it I discovered the solution, but have decided to post this in case another person has the same/similar issue (see bottom)...

After uninstalling the PulseAudio Equalizer and rebooting, I have lost my desktop (GNOME).

Upon powering up the Ubuntu start-up screen displays... then a generic login screen appears, and after logging in, I only get a terminal window... see: http://www.locusplex.us/images/screenshots.jpg

I am running Ubuntu 10.04 LTS Lucid on a Dell Latitude 13.

I have tried:

~$ sudo startx

which returns:

Fatal server error:
Server is already active for display 0
If the server is no longer running, remove /tmp/.X0-lock and start again

removing the file:

~$ sudo rm /tmp/.X0-lock

and trying ('startx') again yields:

_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeA11COTSServerListenerrs: server already running
Fatal server error:
Cannot establish any listening sockets - Make sure the X Server isn't already running

After stopping/starting the X Server:

~$ sudo stop gdm
~$ gdm stop/waiting
~$ sudo start gdm

I am taken back to the login screen like before (see image above).

Stopping the server again ('sudo stop gdm') then trying:

~$ sudo startx

again yields:

_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeA11COTSServerListenerrs: server already running
Fatal server error:
Cannot establish any listening sockets - Make sure the X Server isn't already running

I have searched multiple forums, including Ask Ubuntu and found a few related threads:

GDM Killed at Startup I have attempted the suggestions there with:

sudo apt-get install -f -m --reinstall -u gdm

The log reports:

0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded
Do you want to continue [Y/n] Y

A bit more logging and end with:

Setting up gdm (2.30.2 is.2.30.0-0ubuntu5.2 ...

Next per the suggestion:

~$ sudo dpkg-reconfigure gdm
~$ sudo reboot

Then I find myself back at the previously described login screen.

share|improve this question
1  
Please, instead of putting the solution inside of the question, post an actual answer (and accept it). –  edwin Jul 26 '13 at 1:51
add comment

1 Answer 1

SOLUTION/FIX that worked for me: From Ask Ubuntu, GDM session list borked

Try reinstalling the gnome-session package:
    sudo apt-get install --reinstall gnome-session
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.