Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just replaced Windows 8 on a HP Envy notebook with Ubuntu 12.04 and whereas before, the wireless LED on F12 would be blue to connect with wireless networks, it's now permanently red (not working) and in the Networks tab under System Settings, there is no reference to any sort of ability to connect to a wireless network - as well as wlan0 not existing when I type 'iwconfig' into the command line.

stefanija@stefanija-HP-ENVY-Sleekbook-6-PC:~$ iwconfig

lo no wireless extensions.

eth1 no wireless extensions.

ra0 Ralink STA

      Link Quality:0  Signal level:0  Noise level:0

      Rx invalid nwid:0  invalid crypt:0  invalid misc:0

eth0 no wireless extensions

and

stefanija@stefanija-HP-ENVY-Sleekbook-6-PC:~$ ifconfig wlan0 up wlan0: ERROR while getting interface flags: No such device

I've researched similar issues and followed advice from this tutorial in order to make a suitable driver for RT3290. (as that's appropriate for my wireless card) I then rebooted and checked in the additional drivers to see if it had worked (as the computer still wasn't showing any wireless networks) and the driver was there, was active and in use, but still wasn't picking up any connections.

I also tried this tutorial, however, I couldn't get past opening the file with the archive manager because the system hit an internal error and refused to extract it as an .exe.

I'd be extremely grateful if someone could tell me what happened or how I can fix this, and apologies if I haven't been very specific or posted this in the wrong place, or asked something stupid; I'm quite new to Ubuntu and the forums, heh, so if I've missed parts out or anything, please let me know.

share|improve this question
1  
Please add the result of the terminal command: rfkill list all –  chili555 Jul 25 '13 at 20:54
    
results of 'rfkill list all' 0: hp-wifi: Wireless LAN Soft blocked: no Hard blocked: no 1: hp-bluetooth: Bluetooth Soft blocked: no Hard blocked: no –  Stefanija Jul 26 '13 at 0:33
    
wlan0 is not your wireless interface, ra0 is. I believe your device is included by default in Ubuntu 13.04. I suggest you upgrade. –  chili555 Jul 26 '13 at 12:30
    
I've updated, and Network Manager is still not showing any signs that a wireless option is available, eeep. Is there anything else I can try, do you think, please? –  Stefanija Jul 26 '13 at 16:54
    
Let's have a look at: sudo modprobe rt2800pci and also: modinfo rt2800pci | grep 3290 and finally: dmesg | grep rt2. Thanks. –  chili555 Jul 26 '13 at 22:17
show 4 more comments

1 Answer

up vote 1 down vote accepted

Your device is included by default in the driver rt2800pci in Ubuntu 13.04:

alias: pci:v00001814d00003290sv*sd*bc*sc*i*

Please upgrade to 13.04.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.