Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to disable Compiz in Natty (Ubuntu Classic). I have tried to access this through System > Preferences > Appearance but the "Visual Effects" tab is no longer there.

On previous releases the following gconf key makes the switch:

/desktop/gnome/session/required_components/windowmanager

Value to have visual effects off: metacity

Value to have visual effects on: compiz

On Natty this key is set to gnome-wm which seems to have a lot of added eyecandy (effects/shading) as opposed to metacity in the previous release, and which I would like to turn off.

share|improve this question
1  
Sorry, that works in previous versions. In Natty it says gnome-wm and I don't see anywhere where I can turn off shading and effects. I would expect this to be an option that can be accessed graphically. –  komputes Mar 29 '11 at 16:25
    
I don't have any answer but Komputes question is more than clear. How do you disable Compiz in Natty (Ubuntu Classic)? I also would like to know. And I would prefer not having to logout and login again. –  user13882 Apr 8 '11 at 16:43
    
Have you tried running: –  bntser Apr 10 '11 at 3:02

5 Answers 5

up vote 26 down vote accepted
+50

The easiest way is to use the session that's there to do exactly what you want. ;-)

  • Log out.
  • At the GDM login screen choose the Ubuntu Classic (No effects) session:

    enter image description here

  • Log in.

    → You will be in a classic GNOME session without Compiz. Subsequent logins will use this session as default.

share|improve this answer
    
Using GNOME+Metacity (classic no effects) still seems to have advanced visual effects (shading, click app from panel does zoom icon effect, alt-tab shoes window thumbnail instead of icon). –  komputes May 23 '11 at 15:04
    
any idea how we can get this working in 12.04? Seems like half the settings are now helpfully missing. –  Aram Kocharyan Jun 21 '12 at 11:41

If you don't have some other reason to believe that compiz is running (double check with ps aux | grep compiz), then it sounds like your real question is "what's the relationship between gnome-wm and metacity?" or "how do I turn off shading and effects in Natty?" (Both very good questions, if you ask me.)

share|improve this answer

You would add ' metacity --replace' at startup applications.

1) Open it:

gnome-session-properties

2) Add:

share|improve this answer
    
Yes, it do works. –  desgua Apr 9 '11 at 20:14

Install the package fusion-icon (found in the repositories).

You can run the icon from Applications -> System tools -> Compiz Fusion icon. It will allow you to enable or disable compiz on the fly (replacing it with metacity, for instance)

share|improve this answer
1  
By far the best answer provided you want to switch back and forth without closing your session (and as the appearance tabs previously allowed). –  vaab Oct 30 '11 at 14:44

I would try a different and very simple approach. When you log in before entering you password you have some options in the bottom bar, select "Ubuntu classic (no effects)" and that's it, it will not use compiz. And in your nexts logs it will pre-select as default that option.

Formerly you just had to disable effects and that will be the end of using Compiz. Clicking right button over Desktop background in the last tab.

Hope it helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.