Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to follow this Tutorial to learn flask. I have never used python before and a relatively new to linux too so sorry if I am asking a very basic question.

I have installed python version 2.7.5 and am now trying to create the virtual environment for flask.

I downloaded virtualenv.py and ran the command this command:

python virtualenv.py flask

Then get this error.

New python executable in flask/bin/python
Cannot find sdist setuptools-*.tar.gz
Cannot find sdist pip-*.tar.gz

Thanks in advance for any help.

share|improve this question
1  
Managed to find a different command that worked $ virtualenv flaskapp –  ook Jul 25 '13 at 13:25

1 Answer 1

up vote 1 down vote accepted

I just had the same problem.

To solve it, I just looked for the files on google, pip-.tar.gz and setuptools-.tar.gz, got the latest version of each and put them in the microblog folder.

Got this:

New python executable in flask/bin/python
Installing Setuptools.........................................................................................................................................done.
Installing Pip.....................................................................................................................................................................................................................................................................................................................................done.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.