Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am facing Problems installing packages from downloaded files using terminal. for ex - I downloaded goobox-2.2.0.tar.gz , i extracted using archive manager. Then i opened terminal in folder and typed -

./ configure but then an error pops up permission is denied. I wanted to know how to install programs using terminal and how i can rectify the problems ?

share|improve this question

2 Answers 2

You'll probably need to make the configure file executable - open a terminal, cd to the extracted folder and run the following and see how you get on:

sudo chmod a+x configure
share|improve this answer
    
what is a+x . I am a beginner for terminal –  FOSS DIVERSER Mar 28 '11 at 18:02
    
Wise to be cautious : essentially it's saying 'add execute permissions for all users'. (the a standing for 'all' and the x denoting e'x'ecute) –  DilbertDave Mar 28 '11 at 18:08
    
... to remove execute from all users you would use a-x. –  DilbertDave Mar 28 '11 at 18:11
    
No its still not working. Even logging in as root it give same error (permission denied) while opening terminal in required folder –  FOSS DIVERSER Mar 28 '11 at 18:13
    
Odd - I just downloaded it from ftp.gnome.org/pub/GNOME/sources/goobox/2.2 and not only was the configure file already executable I was able to run it (although I don't have some of the dependencies so it didn't complete) –  DilbertDave Mar 28 '11 at 18:25

The file configure doesn't seem to have the execute (+x) mode set. Without that mode, the system won't execute the file. Set it by running this command:

chmod a+x configure

After that you can build and install this package by running these commands:

./configure
make
sudo make install
share|improve this answer
    
Downloading the package and extracting it showed the the execute flag is indeed set (see my comments in my answer). He has already tried the a+x command and still has the problem (see his comments in my answer) –  DilbertDave Mar 29 '11 at 12:51
    
There is no need to install goobox . I just want to learn how to install any .tz package. I have tried many packets but they give same error permission denied even while running as root. I'm using linux mint 10 same derivative of debian as ubuntu –  FOSS DIVERSER Mar 30 '11 at 18:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.