Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been running Lubuntu 13.04 with the Wifi working fine for a couple weeks until today, when the connection broke and was never able to reconnect successfully. The router is a motorola gateway combo which I'm currently connected to wirelessly via my windows 7 laptop--no problems with it as far as I can discern.

Perhaps importantly the problem seemed to disappear when I disabled the WPA2-PSK AES encryption from the router and I was able to connect the Lubuntu machine to the Wifi, but then I decided to test that 'solution' by manually disconnecting and reconnecting via NetworkManager. When I attempted to reconnect to the unsecured wireless, NetworkManager prompted me for a password. Weird.

My problem is very similar to Why can't my Wifi connect or disconnect? except it's occuring in Lubuntu 13.04.

When I dmesg | grep wlan0

I get a series of messages like this in a loop (i'm not sure where the loop begins, assuming the driver messages are the end):

wlan0: associate with [router mac address] (try 1/3)
wlan0: RX AssocResp from [router mac address] (capab=0x411 status=0 aid=5)
wlan0: associated
wlan0: authenticate with [router mac address]
wlan0: send auth to [mac address] (try 1/3)
wlan0: authenticated
rt73usb 1-8:1.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
rt73usb 1-8:1.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP

NOTES: The messages beginning 'rt73usb' began after the problem at hand; 'rt73usb' is the name of the wireless driver

iwconfig yields

wlan0    IEEE802.11bg ESSID:off/any
         Mode: Managed Access-Point: Not-Associated Tx-Power=20 dBm
         Retry long limit:7 RTS thr:off   Fragment thr:off
         Power Management: off

sudo lshw -c network yields

description: Wireless interface
physical id: 1
bus info: usb@1:8
logical name: wlan0
serial:[mac address]
capabilities: ethernet physical wireless
configuration: broadcast=yes driver=rt73usb driverversion=3.8.0-26-generic \
firmware=1.7 link=no multicast=yes wireless=IEEE 802.11bg

A really strange aspect of this problem is that, as far as I could tell, I had not updated any software packages for hours leading up to the connection problem.

Things I have tried already:

1)soft blocking wifi with rfkill block wifi and restarting the network-manager service with service network-manager restart

2)rebooting

3)killing wpa_supplicant and network-manager

4)I attempted to remove NetworkManager via aptitude to replace with wicd, but was informed that lubuntu-desktop 'depends' on network-manager {@!#$#@!}

5)As mentioned before, I disabled WPA2-PSK AES encryption in the router and seemed to make some headway, but could not reconnect after a manual disconnect.

6)I checked /var/log/apt/history.log to see what software changes had been made but the problem started today(7.24.2013) and history.log just has a Start-Date and End-Date with the same date/time stamp.

Does anyone have any ideas as to what could have caused this? Has anyone successfully removed Network Manager from lubuntu and replaced it?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Removing Network Manager is tricky and can be done but I doubt it is the problem. I also recommend you use WPA2 and AES encryption. Do not use, if you have the option, any mixed mode WPA and WPA2 mode.

I'd suggest you power cycle the router; that is, unplug the power, wait a few moments and plug it back in. Let the router boot and obtain an IP address from your internet service provider. Reboot your computer. Can you connect now? If not, let's try a driver parameter:

sudo modprobe -r rt73usb
sudo modprobe rt73usb nohwcrypt=1

Now can you connect? If so, let's make it persistent:

gksudo gedit /etc/modprobe.d/rt73usb.conf

Add a single line:

options rt73usb nohwcrypt=1

Proofread carefully, save and close gedit. Do NOT make this change and write this file unless you learn, from the steps above, that it makes it possible to connect.

If none of these steps help, update the driver by downloading this file to your desktop: http://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.10/backports-3.10-2.tar.bz2 Right-click it and select 'Extract Here.'

Get a temporary wired ethernet connection and do:

sudo apt-get install linux-headers-generic build-essential
cd Desktop/backports-3.10-2/
make defconfig-wifi
make
sudo make install

The compile process takes a few minutes, so please be patient. Now unload the old driver and load the newest:

sudo modprobe -r rt73usb
sudo modprobe rt73usb

Now can you connect?

share|improve this answer
    
Apologies for the late reply, chili. Power cycling the router resolved the problem, which was quite embarrassing to discover. Thanks for the help. –  egalitarianeric Aug 5 '13 at 22:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.