Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Had dual boot with Ubuntu 12.0 and windows XP. Windows partition got corrupted so I tried to reinstall XP by bootable disk.

But after formatting of C: when setup copied files for installation then upon restart it stuck at grub and didn't resumed automatically.

Now I boot in Linux partition but ubuntu didn't loaded and stuck at checking disk.

So open the maintenance shell and executed command:

sudo dd if=/dev/zero of=/dev/sda

It took around 2hrs for the complete execution of the command. Then when I rebooted the system it showed:

error: no such partition

grub rescue>

After this whenever I try to install windows then after auto restart setup doesn't resumes and stuck at

grub rescue error>

After all this using Bootable USB for Ubuntu I executed this command:

 shred -n 5 -vz /dev/sda

Command executed successfully in 2hrs around.Still no success achieved as now the situation is i am unable to install neither ubuntu nor windows as it stuck at

Installing Ubuntu

attempt to mount a file system with ext4 in scsi1 partion#1 (sda) at / failed.

Installing Windows

stuck at grub rescue error if trying to install windows.

What to do? Is my HardDisk wrecked and need replacement?

share|improve this question

closed as off-topic by karel, Eric Carvalho, bain, 8128, waltinator Jun 21 '14 at 1:10

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

Please answer this...Desperately waiting for reply...Should I move ahead purchasing new HDD or can we sort it out with the old HDD? –  Aditya Singhal Jul 27 '13 at 22:24
Remove the partition metadata: sudo dmraid -E -r /dev/sda –  Joren Sep 22 '13 at 15:28
As I understand this you have completely wiped your /dev/sda drive and filled it with zeros. There is no longer any ext4 file system to mount. Your drive is fine. You need instruction on how to install Ubuntu and Windows. Is this an accurate representation? –  Elder Geek Jun 18 '14 at 23:59
@ElderGeek I don't think he still needs fix for it... A year has passed since he asked. –  Danatela Jun 19 '14 at 4:17
@ElderGeek No doubt a year has been passed but still the problem persist.I have tried every procedure mentioned in my query and also in comments above but still the HDD unable to install any OS –  Aditya Singhal Jun 20 '14 at 19:21