Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

so like many users with a realtek wireless driver I've been having problems getting my wireless to work I'm on a Toshiba Satellite C875 My wifi adapter is RTL8188CE 802.11b/g/n and my kernal is 3.5.0-36-generic.

I managed to find a post on this site with almost my exact problem and a solution, Newly installed Ubuntu on laptop, Wireless will not fuction , however, just like the poster I'm running into issues at the compiling phase. I've managed to work through a few issues that the poster had.

gcc: error: /lib/modules/3.2.0-34-generic-pae/build/include/linux/autoconf.h: 
No such file or directory gcc: fatal error: no input files

This was caused because autoconf.h is now in a different folder (include/generated). I just had to make a copy of it in the include/linux folder and it got further. Same fix worked for modversions.h, which I found in the include/config folder.

after that though my problems with compiling look remarkably similar. Anyone have any suggestions on how to move forward from here.

This is the section of the solution where I'm having issues

cd rtl8192ce_*/
make clean
make
sudo make install
exit
Reboot

After I type in

make clean 

I get this

make[1]: Entering directory `/home/aktd/rtl8192ce_linux_2.6.0006.0321.20/HAL/rtl8192'
rm -fr *.mod.c *.mod *.o .*.cmd *.ko *~
rm -fr .tmp_versions
rm -fr Modules.symvers
rm -fr Module.symvers
rm -fr Module.markers
rm -fr modules.order
rm -fr tags
make[2]: Entering directory `/'
make[2]: *** No rule to make target `clean'.  Stop.
make[2]: Leaving directory `/'
make[1]: *** [clean] Error 2
make[1]: Leaving directory `/home/aktd/rtl8192ce_linux_2.6.0006.0321.201/HAL/rtl8192'
make: *** [clean] Error 2

I feel like I'm so close here, but I just can't quite get it.

oh and I do have linux-headers-3.5.0-36-generic installed before anyone suggests fixing that, as I've seen that come up a lot as a possible solution on forums.

share|improve this question

2 Answers 2

Do you have build-essential installed? You may have better luck with the later version of the driver: https://dl.dropboxusercontent.com/u/58267392/rtl_92ce_92se_92de_8723ae_linux_mac80211_0007.0809.2012.tar.gz

share|improve this answer

Download the driver from Realtek.com for rtl8192ceVA4 or you can use the one for rtl8188ce they are both the same. Then, make sure you have the dependencies installed.

apt-get install gcc build-essential linux-headers-generic linux-headers-`uname -r`

Now you can install the driver. Extract and 'cd' into the folder. Then you should only have to run the following two commands. No need to clean.

sudo make
sudo make install

reboot

I have a Toshiba L855 and this works great with kernel 3.2.0-4 I've heard the macros changed with 3.8, however, I have no experience with 3.5 so if you still get the error I would suggest downloading the zip file from github suggested on this other thread.

share|improve this answer
    
I have a Toshiba L855 –  mchid Jan 28 at 10:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.