Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install ubuntu in my sony CS17G notebook. After selecting the option "Install ubuntu" from the boot menu, I am always getting the error..

init not found. try passing init=bootargs. (initramfs)

After surfing the net I came to know that sudo command will help me to fix the issue which requires a terminal. From the (inittamfs) prompt, how should I open a terminal. On using sudo command, i getting an error that 'sudo not found'.

Please help me in fixing the issue.

share|improve this question

2 Answers 2

It sounds like the installation did not complete or the disk may be damaged or the fs at least corrupt somehow. Boot from the livecd and use the disk utility to check the health of the disk. Run the long SMART self test and make sure the counts for pending, reallocated, and offline sectors are zero. If that looks good, then reinstall.

share|improve this answer
    
Even after booting from the livecd, i face the same problem. –  user13147 Mar 29 '11 at 7:13
    
@Premkumar then it doesn't sound like your system is actually booting from the livecd. –  psusi Mar 29 '11 at 13:51
    
How to boot from the livecd?. I have an option in the boot menu, "run ubuntu without installation". Hope this is the option for livecd. –  user13147 Mar 30 '11 at 5:50
    
@Premkumar yes, and when you choose that, you also get this error? Yet you didn't when you booted from this same cd to install the first time? –  psusi Mar 30 '11 at 13:14
1  
@psusi Ubuntu mounts disks automatically in the livecd. It will not run correctly in Live mode if your damaged disk is existant on the system. I found this out the hard way when i tried to diagnose my disk... ended up buying a SATA-to-USB connectivity kit, connected my SATA drive to the Live environment after booting to the LiveCD. The LiveCD is likely not corrupt, but this issue is likely occurring. –  Thomas W. Aug 3 '11 at 19:10

Boot using a live CD or an alternate ubuntu install (if you have multiple versions as my case). Open System -> administration -> Disk Utility and check the status of all linux partitions. Use 'Check and Repair Filsystem' for each partition (see screen shot) . The partition containing /boot files might have got corrupt. If you get an error while checking the partition, open a terminal window (Application -> accessories -> Terminal) and type

sudo  fsck -y /dev/xxxx 

Replace xxxx with the device name you get from Disk Utility screen where name device written. In the example screen shot it is 'sda5'.

If 'fsck' fixes some thing, re-run it again until it is reported clean.

Reboot without CD now and see if you are able to boot correctly. The procedure described above fixed my problem.

share|improve this answer
    
Thanks. Just bailed out a friend's netbook using your instructions. Spot on. –  klenwell May 6 '12 at 23:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.