Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm on Xubuntu 12.04. I use Hebrew as well as English US.

When I installed Xubuntu I added Hebrew via the Keyboard Layout settings and set ALT-SHIFT as the change layout shortcut. In both cases when I've installed Xubuntu, this worked well and no issues.

After everything worked fine on this laptop, it all of a sudden started to misbehave. Every time I restart, the Keyboard Layout settings revert to only US and the change layout shortcut is forgotten. I re-add the language and update the change layout shortcut and it forgets it again after reboot.

I don't believe I've changed anything, but I must have (or an update caused it?).

Where is the keyboard layout configuration saved?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

You can access your keyboard layout settings using dconf-editor. Start it from Dash, navigate to org → gnome → libgnomekbd → keyboard and select the layout key. Here is my dconf window:

dconf window

As you can see, I use Russian layout along with English. Also, options key holds switching combination. I suppose you should set these keys to ['us', 'il'] and ['grp\tgrp:lalt_lshift_toggle'] correspondingly.

share|improve this answer
    
Looks like this solved it! –  Yon Jul 24 '13 at 15:13
    
Now it started happening again! I did an update of Ubuntu, maybe it overruns it? –  Yon Jul 29 '13 at 15:36
    
Yes, may be. Do settings in Keyboard Layout survive reboot now? –  Danatela Jul 30 '13 at 6:01
    
Yes. Very annoying behavior –  Yon Aug 4 '13 at 1:32
    
I am not sure it's related, but consider tracking this bug: bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/… –  Rmano Mar 7 at 3:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.