Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I did change my packages in synaptic from manually installed to Automatically (they were not manually installed but automatically). Now they are marked for Autoremove.

I tested it with sudo apt-get autoremove and the result is shown below (a reduced version because its almost all packages). I remember last year I had same issue and solved it via Ubuntu forums but the forum is down and I cannot reach the post! Anyone has any idea how to fix this?

sudo apt-get autoremove 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED: 
  unity-asset-pool unity-greeter unity-lens-applications unity-lens-files
  unity-lens-music unity-lens-photos unity-lens-video unity-scope-gdrive
  unity-scope-musicstores unity-scope-video-remote unity-services
  unity-tweak-tool unity-webapps-amazoncloudreader unity-webapps-common
  unity-webapps-facebookmessenger unity-webapps-gmail unity-webapps-googledocs
  unity-webapps-googleplus unity-webapps-launchpad unity-webapps-linkedi
  xserver-xorg-input-wacom xserver-xorg-video-all xserver-xorg-video-ati
  xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-intel
  xserver-xorg-video-mach64 xserver-xorg-video-mga
  xserver-xorg-video-modesetting xserver-xorg-video-neomagic
  xserver-xorg-video-nouveau xserver-xorg-video-openchrome
  xserver-xorg-video-qxl xserver-xorg-video-r128 xserver-xorg-video-radeon
  xserver-xorg-video-s3 xserver-xorg-video-savage
  xserver-xorg-video-siliconmotion xserver-xorg-video-sis
  xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
  xserver-xorg-video-vesa xserver-xorg-video-vmware xul-ext-unity
  xul-ext-webaccounts xul-ext-websites-integration y-ppa-manager yad zenity
  zenity-common zip
0 upgraded, 0 newly installed, 1440 to remove and 0 not upgraded.
After this operation, 3,853 MB disk space will be freed.
Do you want to continue [Y/n]? 
share|improve this question
add comment

2 Answers 2

up vote 4 down vote accepted

Searching aptitude I found this command that did it all

sudo aptitude keep-all

And that was it!

share|improve this answer
add comment

The crazy "apt-get-autoremoving-everything" automatically happens to me every time I install a second desktop environment and delete the default one.

If I answer Yes he completely destroy my linux.

Anyway answering no is not a real solution since apt-get will keep asking you several times to remove those important packages.

But yesterday I found a strange solution.

I run this command: aptitude autoclean

and after that i did again apt-get autoremove and the whole unsane list of packages was completely gone.

Now my system is stable and clean.....and I avoided a lot of trouble

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.