I know there are already many questions about unmet dependencies but none of them helped me so far. Even this really detailed answer (How do I resolve unmet dependencies?) didn't solve my problem.
This is what I did:
sudo add-apt-repository ppa:ubuntu-toolchain-r/test sudo apt-get update sudo apt-get install gcc-4.7
The installation process was interrupted by the following error message:
apt-get install 'gcc-4.7' failed:
dpkg: error processing libquadmath0:i386 (--configure): libquadmath0:i386 4.6.3-1ubuntu5 cannot be configured because libquadmath0:amd64 is in a different version (4.8.1-2ubuntu1~12.04)
dpkg: error processing libquadmath0 (--configure): libquadmath0:amd64 4.8.1-2ubuntu1~12.04 cannot be configured because libquadmath0:i386 is in a different version (4.6.3-1ubuntu5)
Errors were encountered while processing: libquadmath0:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)
After that I'm not able to install or remove any package. I always get the error message:
The following packages have unmet dependencies:
libquadmath0 : Breaks: libquadmath0:i386 (!= 4.8.1-2ubuntu1~12.04) but 4.6.3-1ubuntu5 is to be installed
libquadmath0:i386 : Breaks: libquadmath0 (!= 4.6.3-1ubuntu5) but 4.8.1-2ubuntu1~12.04 is to be installed
I already tried
apt-get -f install which ends with:
Errors were encountered while processing: libquadmath0:i386 libquadmath0 libgfortran3 libgfortran3:i386 libhdf5-serial-1.8.4:i386 liblapack3gf:i386 libnetcdf6:i386 libnetcdf-dev:i386 ncview:i386 netcdf-bin:i386
I also tried
dist-upgrade. But any upgrade won't work either for the same reason, a normal package installation won't work.
How I understand the error messages that I get, is that the 386 version of the package libquadmath0 has a different version number then the amd64 version. Ok, I see, that this can cause some troubles, but how can I solve this?