Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When installing wine1.6 and wine1.6-amd64 from ppa:ubuntu-wine on Kubuntu 12.10 (quantal), it always asked me for installing wine1.6-i386

root@ezgo64:/etc/apt/sources.list.d# LC_ALL=C apt-get install wine1.6
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine1.6 : Depends: wine1.6-i386 (= 1.6-0ubuntu1~ppa1) but it is not installable
           Recommends: ttf-mscorefonts-installer but it is not installable
           Recommends: fonts-horai-umefont but it is not going to be installed
           Recommends: fonts-unfonts-core but it is not going to be installed
           Recommends: winbind but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@ezgo64:/etc/apt/sources.list.d# LC_ALL=C apt-get install wine1.6 wine1.6-amd64
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine1.6 : Depends: wine1.6-i386 (= 1.6-0ubuntu1~ppa1) but it is not installable
           Recommends: ttf-mscorefonts-installer but it is not installable
           Recommends: fonts-horai-umefont but it is not going to be installed
           Recommends: fonts-unfonts-core but it is not going to be installed
           Recommends: winbind but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

However, how could I install wine1.6-i386 on a amd64 box? Therefore I need to download the package, extract it and change the dependency to remove wine1.6-i386 so that I can install this amd64 version of wine1.6.

wine1.5 has the same problem.

Any suggestions?

new information added: Thanks for suggestions. However when I tried to install wine1.6-i386, it asked for a lot of other i386 packages like libgstreamer0.10-0:i386. I was not able to install it and didn't know how to solve such dependencies. Any help will be appreciated.

share|improve this question
    
Additional information: using this ppa repository I couldn't get wine1.6-i386 installed, even using dpkg --add-architecture i386 as this answer suggested: askubuntu.com/questions/214181/installing-wine-on-64-bit?rq=1 –  Franklin Jul 23 '13 at 8:41
    
The best way to add additional information to your question is by editing it, with the edit button. It is better visible that way, and comments are mainly for secondary, temporary purposes. Comments are removed under a variety of circumstances. Anything important to your question should be in the question itself. –  Danatela Jul 23 '13 at 9:05
    
Also check this question. –  Danatela Jul 23 '13 at 9:18
add comment

2 Answers 2

I found the answer... at least a solution.

Can't install wine (or ia32-libs) in Ubuntu 12.10 64 bit

Using /etc/apt/preferences to assign Pin-Priority would solve the dependencies problems while installing wine-i386. However, in some of my machines it would remove almost all kde packages and I need to re-install them back after installing i386 packages.

share|improve this answer
    
And some ppa would create this dependency problem too. I need to remove kubuntu backports ppa to make it work. –  Franklin Aug 6 '13 at 8:03
add comment

The wine1.x metapackage depends on both wine1.x-amd64 and wine1.x-i386 actual packages. These correspond to support for amd64 and i386 windows applications. 64 bit systems can still run 32 bit binaries providing they have 32 bit versions of all the necessary libraries.

You can install only the wine1.x-amd64 package to avoid the multiarch dependency, but you will then not be able to load 32-bit windows applications, which still seems to cover a significant fraction of games and applications.

I'm not sure about the dependency problems, but I would look for general fixing broken package answers rather than anything wine-specific.

share|improve this answer
    
as I have said in additional information above, there are a lot i386 dependencies needed to install wine1.6-i386. Should I solve all these dependencies? –  Franklin Jul 23 '13 at 10:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.