Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently built a new computer with the intent to dual boot Windows 8 and Ubuntu 12.04. I first installed Windows 8, and elected to do so in UEFI mode with Secure Boot enabled. My understanding is that I should be able to install Ubuntu 12.04 LTS alongside Windows 8.

I burned the 12.04 image to DVD and was able to boot (from the installation DVD) in EFI mode as expected. What was unexpected was the installer's inability to recognize my existing Windows 8 installation on the machine.

Based on my reading of previous threads, I went ahead and ran boot-repair from the Ubuntu Live DVD (that is, "try Ubuntu without installing"); the output information is here: http://paste.ubuntu.com/5902713/

The Windows 8 installation is on drive sdb, and I noted in the output (line 189) that os-prober does not detect Windows on sdb4 where I believe it should be found.

In original dump files I noticed lines which stated "/dev/sdb1 ends after the last sector of /dev/sdb" for sda/b/c, and (following instructions from another thread) used gdisk to generate fresh protective MBRs for each.

The installer is still unable to detect my installation for Windows 8. Instead, it presents me with only the following options:

  • Erase disk and install Ubuntu
  • Something else

What actions should I take? Any help would be very much appreciated. Thanks!

UPDATE Thanks again for the help so far everyone! I went ahead and partitioned the drives manually for the install; the brief summary is as follows:

  • sda(1-3): Microsoft (MS) reserved; NTFS data; swap
  • sdb(1-5): MS (EFI install); EFI; MS reserved; Windows 8 OS; Ubuntu 12.04.2 OS (/)
  • sdc(1-3): MS reserved; NTFS data; ext4 data (/home)

I completed the install, and have no problems booting into Windows 8. However, I have not been able to boot into Ubuntu. Initially, prioritizing ubuntu in the BIOS boot order briefly showed an Ubuntu splash screen before going black and hanging. Since that first attempt, the BIOS skips Ubuntu entirely and progresses straight to booting Windows.

I went back to the installation DVD and "tried Ubuntu" to run boot-repair again. The updated output information is here: http://paste.ubuntu.com/5909477/

My thought is to try and run boot-repair after backing up Windows. Is that the right course of action, or what would you all recommend? Thanks for your continued help!

Brian

share|improve this question
    
Welcome to AskUbuntu! Please read Installing on a Pre-Installed Windows 8 System (UEFI Supported). –  Danatela Jul 23 '13 at 4:06

3 Answers 3

up vote 2 down vote accepted

Installing Ubuntu

If your system does not detect Windows 8 OS but want to check where it is, you could just mount all /dev/sdaN (N is number, you can type ls /dev/sda* to view all partitions) and check which partition is for windows.

If you want to allocate another partition for Ubuntu (Reommanded), minimize a partiton, and mount the free space as ext4 file system and set it as root on the installation window.

Then GRUB would not detect Windows 8, so..

Try 'Boot-repair'.

sudo apt-get install boot-repair
boot-repair

It would fix almost all GRUB/bootloader problems. I solved my problems too with it.

Another solution (Easy):

Check your System settings (BIOS settings). If there is Windows 8 bootloader, try exiting GRUB when booting. Then the Windows 8 bootloader screen would appear.

share|improve this answer
    
I'm absolutely willing to try this if you think it will help. I'd just like to ask for clarification: is this worthwhile to try given that I haven't yet installed Linux? If the boot repair is capable of repairing some deficiency with my current Windows installation, I'm all for it. –  Brian Jul 23 '13 at 21:43
    
@Brian Sorry I edited the answer. –  minmaxavg Jul 24 '13 at 10:43

First, disable Secure Boot, at least temporarily. Even if you want the feature in the long run, it's a major potential source of problems, so it will simplify your debugging to disable Secure Boot for now. Once you get everything booting without Secure Boot, you can re-enable the feature and deal with its specific issues (if there are any) knowing that they really are Secure Boot issues.

Second, I see no evidence in your Boot Repair output of any Linux boot loader. My suspicion is that Boot Repair has neglected to report them. (I've seen this happen in the past, although it's rare.) Still, you might want to look for them manually. If you can boot Linux normally, mount /dev/sdb2 to /boot/efi and the following command should locate them:

ls -l `find /boot -iname "*.efi"`

You'll probably see a /boot/efi/EFI/ubuntu directory with shim.efi and grubx64.efi files. If there's no evidence of such files, please edit your question to add the output of that command and the contents of your /etc/fstab file, since there's something fishy going on and understanding it may be important in providing a solution.

Third, I recommend you create a USB flash drive or CD-R with my rEFInd boot manager. (There are download links for prepared images for both types of media.) Try booting with it and see if it presents an option to boot Windows. If it works, and if rEFInd also offers options to boot Ubuntu that work, you might consider installing the rEFInd Debian package. Be sure to mount /dev/sdb2 to /boot/efi before you do this, though. (For some reason, your installation doesn't seem to be mounting the ESP automatically. You can fix this by editing /etc/fstab.) Note that if you install rEFInd, you'll need to jump through some extra hoops to get Secure Boot working.

share|improve this answer
    
Thanks Rod, I did some reading based on oldfred's reply and it looks like my interest in keeping Secure Boot enabled was likely misguided. I'll disable that as soon as I'm home. To your second observation, I think the confusion is my fault. I've updated my question to be clear - I haven't yet installed Ubuntu. I generated the boot-repair report while "trying Ubuntu" from the installation disk. In light of that information, would you stand by your recommendation (third), or is there another course of action you'd recommend? Thanks again! –  Brian Jul 23 '13 at 21:51
    
Sorry; I think I misread "...installer's inability to recognize my existing Windows 8..." as "...GRUB's inability to recognize my existing Windows 8..." Anyhow, the installer probably does recognize Windows 8; it's just not giving you an option to automatically shrink its partition. Do that manually and run the installer again, or use the "something else" installer option to adjust your partitions manually. Making a backup of Windows before you proceed is wise; there's always a risk of failure. Don't bother with rEFInd at this point (but it may be useful for some types of boot problems). –  Rod Smith Jul 24 '13 at 1:02
    
Thanks for continuing to help! The output from os-prober on line 189 of the boot-repair dump had me concerned, but further examination (e.g. the boot info summary for sdb4 on line 56) has me thinking you're right. I've already shrunk the partition in Windows using disk management, so if you believe it prudent, I think I can continue with installation using the "something else" option. I'll backup Windows before I proceed as well. I'll keep this thread updated; if you have any further thoughts, please let me know! –  Brian Jul 24 '13 at 1:25
    
Rod, your suggestion was a good one. I went ahead and installed using the "something else" option, and had success. I've been fighting with the installation for days, thinking it wasn't installing correctly because my monitor would go black (actually, no signal) after the Ubuntu splash screen. I've just realized in the last 10 minutes that the signal was lost because, for whatever reason, the DisplayPort signal is not active after installing the nvidia-current drivers. Working on that now! –  Brian Jul 27 '13 at 14:18

Is Windows still hibernated? The hiberfile check will prevent NTFS driver from loading the NTFS partition so the Windows install cannot be seen. Fast Startup off/hibernation http://www.eightforums.com/tutorials/6320-fast-startup-turn-off-windows-8-a.html

What drive are you installing Ubuntu? I would keep systems on separate drives. Even thought you may be only booting from one efi partition on the boot drive, I might configure an efi partition at the beginning of every drive, if only for future use. Then you could make each drive boot without any other drive.

If you are installing both systems yourself, do you really want secure boot? http://www.zdnet.com/torvalds-clarifies-linuxs-windows-8-secure-boot-position-7000011918/ the whole UEFI thing is more about control than security

Update: Definitely backup Windows and the efi partition. Run the Boot-Repair fixes, but you may not want the rename function it does. That is required for those systems that only boot the Windows efi file. Many have modified UEFI to only boot Windows so Boot-Repair renames shim and backs up and renames the original Windows efi file. You then may not be able to directly boot Windows from UEFI but then Ubuntu would work. If you can boot both Windows & Ubuntu then rename not required. Boot-Repair can undo the rename. Boot-Repair copied /EFI/ubuntu/grubx64.efi to /EFI/Boot/bootx64.efi (in case the BIOS is hard-coded to boot into /EFI/Boot/bootx64.efi or secure boot signed GRUB file shimx64.efi. Renamed files: /EFI/Boot/bkpbootx64.efi /EFI/Microsoft/Boot/bkpbootmgfw.efi To undo & to rename files to their original names, you just need to tick the "Restore EFI backups" option of Boot-Repair.

If you are starting to boot Ubuntu, do you get grub menu? Or does shift from UEFI/BIOS or with some UEFI escape give grub menu. Then issue may be video related and system has booted past grub issues. What video card/chip do you have? And from grub menu, add nomodeset in place of quiet splash on linux line in boot stanza.

Editing the GRUB 2 Menu During Boot https://help.ubuntu.com/community/Grub2/Troubleshooting

share|improve this answer
    
An interesting question, I'll check that as soon as I'm home on my new PC! I'm fairly certain I disabled the fast boot option in my BIOS settings, but I haven't made any adjustments to fast startup in Windows. As for your drive question, my intent was to use sdb for Linux, the same disk on which I installed Windows. My thought was to keep the operating systems on one drive, additional program installations on the sdc (my other SSD), and data on sda (my HDD). I'll take your suggestion into consideration - are there any complications to having multiple boot drives? –  Brian Jul 23 '13 at 21:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.