Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 10.04. My external hdd is not automounted as I connect it and I can't mount it manually using:

sudo mount -t ntfs-3g /dev/sdc1 /media/external

No error is given but the output of the mount command shows that it is not mounted and shows that the device is detected as,
sudo fdisk -l gives:

Disk /dev/sdc: 2000.4 GB, 2000365289472 bytes
255 heads, 63 sectors/track, 243197 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0005f107

and blkid gives,

/dev/sdc1: LABEL="My Passport" UUID="F474B7AA74B76DCC" TYPE="ntfs"

Any help is appreciated.

share|improve this question

closed as off-topic by Luis Jul 24 '13 at 2:02

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

    
Ubuntu 10.04 is eol. Since it is not supported anymore your question is of topic. I recommend upgrading to 13.04 or 12.04 lts. –  jeroen Jul 23 '13 at 1:33
    
Just try this command sudo mount.ntfs /dev/sdc1 /media/external –  Danatela Jul 23 '13 at 1:50
    
Since the drive is NTFS formatted, can you try plugging it to a Windows Machine, and see if it works. If it does, safely remove it, and try it with Ubuntu. –  Mitch Jul 23 '13 at 7:04
    
jeroen: I want to upgrade to 12.04 so I need to make a backup and I am facing this issue.Danatela: sudo mount.ntfs /dev/sdc1 /media/external gives "bus error". –  user177506 Jul 24 '13 at 1:03

Browse other questions tagged or ask your own question.