Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know this is a common problem and I've been reading related questions, but none have helped me so far. Please help if you are able. it's been a week and still no progress on my own attempts to repair


I'm a new Ubuntu user and recently installed 12.04 on my PC tower that is only used for the TV (mainly Netflix). It's a basic Lenovo desktop (can give details if necessary) and I'm connecting it with an HDMI cord to a Sony Bravia TV that has been used for Windows OS (7 & 8) without problem. I have picture, just no sound. When I go to system settings > sound, HDMI/Display Port is an option. The only other option is Analog Output. Sound works when headphones are connected to the tower.

Note: I don't have computer monitors in my household, just the 32" bravia and a 24" (?) TV which runs off a Windows laptop. I also don't have computer speakers.

update: HDMI/Display Port is not longer an option, probably goofed something up. "dummy control" is in its place now. Analog control went away when HDMI/Display Port disappeared; again probably something I unknowingly screwed up.

this is my result from aplay-L: http://pastebin.com/w0DLTsVj

is it possible that this problem is related to my graphics card? it's what came on the Lenovo; hynix semiconductor (hyundai electronics) radeon HD 3000. as in the comments below, I installed pavucontrol, but no luck; dummy control is still my only option.

share|improve this question
    
Try running "pavucontrol" from a terminal window and check the hdmi output is selected as the default audio device. If you aren't using pulseaudio or are have trouble then include the output of running "aplay -l" –  Lionel Port Jul 30 '13 at 0:48
    
"pavucontrol" yields not installed. Now that I've been messing with crap, HDMI output is no longer an option. I now have "dummy output". –  Madison Jul 30 '13 at 0:59
    
aplay-L: pastebin.com/w0DLTsVj –  Madison Jul 30 '13 at 1:06
    
From the aplay list it looks like you are good driver wise. Your hardware is recognised and configured. It probably just a matter of going into the sound control app (there is one in gnome volume control) and select the output device. If you want to use pavucontrol you can just run "sudo apt-get install pavucontrol" to install it. –  Lionel Port Jul 30 '13 at 2:27
    
pavucontrol is only showing dummy control as an output device. –  Madison Jul 30 '13 at 3:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.