Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First of all I wanted to say that I am pretty new to Linux, but I admire the system a lot!

Ok, so after having ubuntu 13.04 for a week, I was experimenting with compiz cube effects and the system crashed. After rebooting I had the following error "System is running in low graphics mode". I tried several solutions posted on the net and finally installing gdm solved the problem. However not entirely. At the moment I do not have this error anymore, but the graphic is not working perfectly. The autohide unity launcher leaves the gray space (the wallpaper is not stretched to that area). The transparancy of the pannels doesnt work anymore and the worst thing I noticed is much higher usage of CPU.

Basing on the above I am thinking that the graphics driver doesnt work properly. Is that correct?

Now my hardware: I have Lenovo IdeaPad y580 laptop with i7 processor, intel built-in graphic card and GeForce 660M. I know that this works under this Optimus technology, thus first day of having Ubuntu I installed Bumblebee, which was working ok (there was a significant difference in FPS between glxspheres and optirun glxspheres). However I did not configurate any application to work with this optirun command, so I am thinking that everything (unity, cairo dock (no openGL), compiz) was using this Intel Video Card.

Could you please give me any advice how to solve these problems? Am I thinking correctly that it must be something with the Intel driver? Should I be using Geforce for compiz effects or cairo dock (if so, how?).

Thanks, Marcin

share|improve this question
add comment

2 Answers

Make sure the update runs to remove the previous repositories then:

sudo apt-get update

This will only download gdm to our archive, make sure the operation completes correctly before moving to the next step:

sudo apt-get -d install --reinstall gdm

When the package is being removed go ahead and stop xserver as the prompts says, then:

sudo apt-get remove --purge gdm

Now we have the new gdm installed with a new configuration, next we need to get rid of xgl and the associated files:

sudo apt-get install gdm

Then install the following:

sudo apt-get remove --purge xserver-xgl compiz compiz-plugins compiz-core compiz-manager csm cgwd cgwd-themes

And

sudo apt-get install --reinstall compiz compiz-core compiz-fusion-plugins-extra compiz-fusion-plugins-main compiz-gnome compiz-plugins libcompizconfig0

Remove the existing xorg using the following command

sudo apt-get remove --purge xserver-xorg

Install xorg using the following command

 sudo apt-get install xserver-xorg

Choose the driver 'ati' and when you get to monitor resolution choose the resolution you want to run and any resolution ABOVE that resolution should be removed. Once that is done issue the following:

sudo dpkg-reconfigure -phigh xserver-xorg
sudo reboot
share|improve this answer
add comment

Compiz is something that can easily be broken by messing around with too many settings but here is a link that may help reset everything without the need for a reinstall:

http://techiesf1.blogspot.co.uk/2013/03/ubuntu-is-running-in-low-graphics-mode.html

at the end choose nvidia instead of ati though...

share|improve this answer
1  
Welcome to Ask Ubuntu. Could you please summarise the main points from that page as the link may stop working in the future? –  papukaija Jul 22 '13 at 19:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.