Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

My PC has the latest version of ubuntu installed (13.04) and i usually watch movies (also on DVDs) with VLC Player.

Now that i havent watched a dvd in long time i wanted to try it again. But it didn't worked. VLC player starts and switches from play to pause while the drive makes noise in the same rythm. It looks like it is stuck in an infinite loop. the movie player (ubuntu builtin player) gives a warning that says he couldnt play the dvd (no reason said).

i tried more than just one dvd, they all didn't work. half a year ago i watched dvds with vlc player and everything worked fine. maybe there's a problem with third-party-software? does anyone have the same problem? could you please help me with that?

share|improve this question

marked as duplicate by Jorge Castro, karel, guntbert, Warren Hill, psusi Oct 18 '13 at 14:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

1 Answer 1

up vote 5 down vote accepted

There are two ways to do this. The first way is to buy the Fluendo DVD Player from Ubuntu Software Center. But there is also a free way to enable DVD playback in players like VLC and Totem.

First you need to install this package (if not yet installed): https://apps.ubuntu.com/cat/applications/libdvdread4/

Then you need to open a terminal and put the following command:

sudo /usr/share/doc/libdvdread4/install-css.sh

You'll have to enter your password. It will not show on the screen while typing, this is normal.

Now DVD playback should work in VLC, Totem and other players.

share|improve this answer
    
thank you chocobai, your answer helped me. do you have an idea why it suddenly didn't work? –  Jens Grünwald Jul 22 '13 at 15:40
    
Since I do not own any DVDs (I tried on my pc as I read your Question, I used a DVD from my brother) I don't know how this was on previous versions. It didn't work, so I found that article on omgubuntu and it worked: omgubuntu.co.uk/2012/10/how-to-enable-dvd-playback-in-ubuntu I'm glad I could help you. –  verpfeilt Jul 22 '13 at 16:32
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.