Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a netbook where I use both Windows 7 and Ubuntu 12.04 LTS. One month ago I changed the router, and since that time, using Ubuntu, I can connect to Wifi but not to internet. Anyway, using Windows I can connect to Wifi and to internet. Moreover, using an ethernet cable, I can connect to internet also with Ubuntu. Someone has ideas?

iwconfig

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"SitecomF6E142"  
      Mode:Managed  Frequency:2.412 GHz  Access Point: 00:0C:F6:F6:E1:42   
      Bit Rate=150 Mb/s   Tx-Power=14 dBm   
      Retry  long limit:7   RTS thr:off   Fragment thr:off
      Encryption key:off
      Power Management:on
      Link Quality=59/70  Signal level=-51 dBm  
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:3  Invalid misc:167   Missed beacon:0

eth0      no wireless extensions.

ifconfig

eth0      Link encap:Ethernet  IndirizzoHW c8:0a:a9:0d:bd:70  
      indirizzo inet:192.168.0.104  Bcast:192.168.0.255  Maschera:255.255.255.0
      indirizzo inet6: fe80::ca0a:a9ff:fe0d:bd70/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:6925 errors:0 dropped:0 overruns:0 frame:0
      TX packets:6214 errors:0 dropped:0 overruns:0 carrier:1
      collisioni:0 txqueuelen:1000 
      Byte RX:5865027 (5.8 MB)  Byte TX:975928 (975.9 KB)
      Interrupt:46 

lo        Link encap:Loopback locale  
      indirizzo inet:127.0.0.1  Maschera:255.0.0.0
      indirizzo inet6: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:16436  Metric:1
      RX packets:808 errors:0 dropped:0 overruns:0 frame:0
      TX packets:808 errors:0 dropped:0 overruns:0 carrier:0
      collisioni:0 txqueuelen:0 
      Byte RX:70313 (70.3 KB)  Byte TX:70313 (70.3 KB)

wlan0     Link encap:Ethernet  IndirizzoHW 00:1e:64:36:48:0a  
      indirizzo inet:192.168.0.112  Bcast:192.168.0.255  Maschera:255.255.255.0
      indirizzo inet6: fe80::21e:64ff:fe36:480a/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:625 errors:0 dropped:0 overruns:0 frame:0
      TX packets:565 errors:0 dropped:0 overruns:0 carrier:0
      collisioni:0 txqueuelen:1000 
      Byte RX:91559 (91.5 KB)  Byte TX:71963 (71.9 KB)

nm-tool

NetworkManager Tool

State: connected (global)

- Device: wlan0  [SitecomF6E142] -----------------------------------------------
  Type:              802.11 WiFi
  Driver:            iwlwifi
  State:             connected
  Default:           no
  HW Address:        00:1E:64:36:48:0A

  Capabilities:
    Speed:           150 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    *SitecomF6E142:  Infra, 00:0C:F6:F6:E1:42, Freq 2412 MHz, Rate 54 Mb/s, Strength 78 WPA2

  IPv4 Settings:
    Address:         192.168.0.112
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.0.1

    DNS:             192.168.0.1


- Device: eth0  [Connessione via cavo 1] ---------------------------------------
  Type:              Wired
  Driver:            atl1c
  State:             connected
  Default:           yes
  HW Address:        C8:0A:A9:0D:BD:70

  Capabilities:
    Carrier Detect:  yes
    Speed:           1000 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         192.168.0.104
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.0.1

    DNS:             192.168.0.1

lshw -C network

 *-network               
   description: Ethernet interface
   product: AR8131 Gigabit Ethernet
   vendor: Atheros Communications Inc.
   physical id: 0
   bus info: pci@0000:01:00.0
   logical name: eth0
   version: c0
   serial: c8:0a:a9:0d:bd:70
   size: 1Gbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.0-NAPI duplex=full firmware=N/A ip=192.168.0.104 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
   resources: irq:46 memory:d3500000-d353ffff ioport:2000(size=128)
  *-network
   description: Wireless interface
   product: Centrino Wireless-N 1000
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: wlan0
   version: 00
   serial: 00:1e:64:36:48:0a
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlwifi driverversion=3.2.0-49-generic firmware=39.31.5.1 build 35138 ip=192.168.0.112 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
   resources: irq:44 memory:d2500000-d2501fff

Need something else? Thank you.

share|improve this question
    
Please see: askubuntu.com/questions/119578/… –  chili555 Jul 22 '13 at 12:32

1 Answer 1

Avoid using same range IP address for your network interfaces.

You can simply avoid this by giving one the 192.168.0.5 and the other 192.168.10.5 with the same 255.255.255.0 mask; Given that your AP can handle your new IP range, everything should be OK now.

share|improve this answer
    
The problem wasn't the same range IP (it was setted in automatic by the OS).. Anyway I solve the problem following the instructions given at the link that chili555 suggests. –  Carlo Jul 24 '13 at 10:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.