Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Xubuntu 13.04 in VirtualBox on my iMac, and have discovered that devices and optical media don't show up in the VM at all. For example, USB drives and CDs mount on my Mac OS desktop but not anywhere in Xubuntu.

I've done a heap of googling about this problem, but all I found were huge technical discussions which lead nowhere, and didn't help me (a complete newbie Linux user) at all. I'd appreciate straightforward instructions, and if they involve using Terminal (which I assume they will) please be aware I have no prior knowledge of command line stuff and am learning as I go, so I'll need everything explained to me. Thanks in advance!

Update: I've fixed the USB problem - turns out USB 2.0 had to be enabled separately and that's what my USB drives are. I still can't mount CDs/DVDs though.

share|improve this question
add comment

1 Answer

About CDs: open the virtual machine settings (in the VirtualBox application), go to the Storage tab, ensure that there is a virtual CD/DVD drive (if not, add one using the buttons at the bottom). Now, click the button at the right, to either assign the iso to the virtual CD drive, or select the host cd drive.

More information is in the VirtualBox user manual.

About the USB drives: click on the virtual machine "Devices" menu (I mean, not Xubuntu menu, but the virtual machine window Machine/View/Devices/Help menu). Choose the USb device that you want to pass to the virtual machine. Now ti will be passed to the guest (Xubuntu).

Alternatively, open the virtual machine settings, open the tab USB, and either add a filter for all devices, or for the device that you want to pass.

More information is in the VirtualBox user manual.

share|improve this answer
    
Ok, I appear to already have a virtual cd/dvd drive, but it still says 'empty' even though I put a DVD in. There is a box unchecked 'live cd/dvd'; what does that mean? I set up the USB thing to filter for my USB drive, but that didn't mount either. –  dbaker Jul 22 '13 at 11:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.