Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am not able to run Ubuntu touch core apps properly. It was running fine until I installed QT5 along with QT4. I tried removing all and installing ubuntu-sdk from scratch. But still no luck.

Error

Error: SQL: database version mismatch
[CLOCK] TimerPage loaded
QSqlDatabasePrivate::database: unable to open database: " " 
QSqlQuery::prepare: database not open
[CLOCK][ERROR] Error creating WorldClock table in db:Error:  

When I run the app, header, divider is not shown and controls not shown on swiping from the bottom. background is not shown properly.

How do I solve this sql db version mismatch

share|improve this question

1 Answer 1

I had a similar issue and I solved it by deleting the database files from the file system. Of course you will lose all data you had inserted in the application.

You'll find the files to delete under directory:

~/.local/share/Qt Project/QtQmlViewer/QML/OfflineStorage/Databases

Check all the *.ini files until you find the one matching your application. Delete that one as well as its .sqlite counterpart. After that I could run my app again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.