Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Last week I tried Ubuntu Touch on my Nexus 4, and it was easy to install en to recover to android. So today I wanted to show the preview to some friends, and something has gone very wrong.


Current status:

On boot I get a black screen

bootloader does work (volume down + power on)

Recovery mode gives me black screen


What I have done:

1 Updated my system (sudo apt-get update)

2 Installed (sudo phablet-flash -b)

After that my phone hang on the Google logo while booting. Started recovery mode and started poking around. <- probably my first mistake.

3 Tried to reinstall (sudo phablet-flash -b) but didn't work. Gave error that I should use -d.

4 Tried reinstall with (phablet-flash -d grouper -b).


Can someone help me out on getting android back on my phone, because I don't know what to do. "adb devices" tells me that there are no devices attached, so I really dont know how to reinstall or recover.

share|improve this question
add comment

2 Answers

Some obvious issues:

(1.) The command sudo apt-get update needs to be followed by sudo apt-get upgrade. This will likely load a newer phablet-flash version.

Or combine into:

sudo apt-get update && sudo apt-get upgrade

(2.) The command phablet-flash -d grouper -b will likely brick your Nexus 4 (mako). The 'grouper' tag is for 'Nexus 7' ..


To recover:

Put the device in 'Recovery Mode', and then run:

phablet-flash -d mako -b

IF that fails, revert to factory / Android setup.

https://wiki.ubuntu.com/Touch/Install

Look for: 'Restoring Android'

( You may also need to put phone into 'Recovery Mode' for this to work. )

share|improve this answer
add comment

Just for your information. In the Release Notes, Device Specific Issues, there is a paragraph for the Nexus4

In rare circumstances, the Nexus4 may get into a state where it may not boot at all after the battery is drained (even into recovery). If this happens, the only way to restore it is to disassemble the back of the phone and unplug/plug the battery connector. See Power Consumption to learn how to avoid discharging the phone completely.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.