Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I give in this command to find out which graphic card is present in my laptop working on Ubuntu 12.10:

lspci | grep VGA

I get the following result:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) 01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Caicos [Radeon HD 6400M/7400M Series]

From the following link I read that there is something called integrated graphic card and a "discrete" one;

How to manage graphics cards?
Please correct me if my logical consequences are not right

I assume that I have to install a driver for the discrete graphic driver. I have been trying to install a graphic driver for many times but I didn't manage it at all.

I've seen that many people have problems installing a working graphic driver and I did read many questions and followed many many suggestions but the results were merely the same;
You could read at booting when I tried to install the propriatery AMD graphic driver - as example from the Software Center :

The disk drive for /dev/mapper/cryptswap1 is not ready yet or not present

Can someone give me a hint to install the correct propriatery graphic driver for my graphic card?

share|improve this question
add comment

1 Answer

I wound install proprientary ATI radeon dirver if I were You. You should search for driver or additional drivers in the settings.

Normally the descrite card is automatically used when the integrated one is not enough.

As for the integrated -- You have Intel card and You probably have the Intel drivers for it installed already.

share|improve this answer
    
I've already tried to install the proprietary ATI drivers from the settings, from the Ubuntu Software Center and from Synaptics... And once I guess also manually from the website but I might've done there some things wrong; not sure.. but did not work either. –  Burak Jul 21 '13 at 21:26
    
Why go manually -- did the settings way failed You? –  Adobe Jul 21 '13 at 21:28
    
Yes. I've had not the working output of the command fglrxinfo and when I did boot I've had the problem that I could log in but I've had no Unity working after login = no top panel and side panel... –  Burak Jul 21 '13 at 21:31
    
Sound as if You didn't login to unity -- but instead to some other thing (kdm or gnome). You should be able to choose the desktop on login (unless You turn on automatic login). Does the screen looks ok (resolution)? –  Adobe Jul 21 '13 at 21:34
    
The resolution is fine; its only that I want to get more use of the graphic card that is present. I don't know what you mean at all with logging in but my login was as usual as always, only that I could see only wallpaper and the icons but terminal did work as usual. I guess Unity and Compiz did not work there –  Burak Jul 21 '13 at 22:10
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.