Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was trying to install elementary theme over unity in Ubuntu 12.04, parallel to my win7. Both are running fine till this mishap by me today. The apt-get couldn't install the dependencies hence crashed.

Now I tried to rectify with sudo apt-get -f install at one stage when i got this output:

[835:15] sources.list.d bash $ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  elementary-theme
The following NEW packages will be installed:
  elementary-theme
0 upgraded, 1 newly installed, 0 to remove and 45 not upgraded.
3 not fully installed or removed.
Need to get 0 B/133 kB of archives.
After this operation, 1,497 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
(Reading database ... 257956 files and directories currently installed.)
Unpacking elementary-theme (from .../elementary-theme_3.4->0~r649+pkg293~precise1_all.deb) ...
dpkg: error processing /var/cache/apt/archives/elementary-theme_3.4->0~r649+pkg293~precise1_all.deb (--unpack):
trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Range/slider.png', which is also in package elementary 3.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/elementary-theme_3.4-0~r649+pkg293~precise1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Now how can I sort this out as this is not giving me any chance to update the local installations?

Update: @Jorge , my findings to your patch is as follows:

[849:6] ~ bash $ sudo dpkg -i --force-overwrite /var/cache/apt/archives/elementary-theme_3.4-0~r649+pkg293~precise1_all.deb
(Reading database ... 257950 files and directories currently installed.)
Unpacking elementary-theme (from .../elementary-theme_3.4-0~r649+pkg293~precise1_all.deb) ...
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Range/slider.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Range/trough.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Range/slider-prelight.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Handle/dimple.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Handle/pane-horiz.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Handle/resize_grip.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Handle/pane-vert.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Sidebar/handle.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/nautilus/right_slider_normal.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/nautilus/breadcrumb_prelight.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/nautilus/left_slider_normal.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/nautilus/button/right_slider_normal_alt.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/nautilus/button/left_slider_normal_alt.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/nautilus/button/breadcrumb_prelight.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/nautilus/button/breadcrumb_normal.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/nautilus/old/right_slider_normal.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/nautilus/old/breadcrumb_prelight.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/nautilus/old/left_slider_normal.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/nautilus/old/breadcrumb_normal.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/nautilus/breadcrumb_normal.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/nautilus/extra-widget.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Button/normal.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Button/insensitive.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Button/mode_prelight.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Button/selected.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Button/prelight.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Button/mode_normal.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Button/mode_pressed.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/gtkrc', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Apps/steadyflow.rc', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Apps/xfce-panel.rc', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Apps/xfce-panel/panel-dark.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Icons/media-skip-forward.svg', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Icons/media-playback-pause.svg', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Icons/media-skip-backward.svg', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Icons/media-playback-start.svg', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-2.0/Icons/close.png', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/metacity-1/metacity-theme-3.xml', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/index.theme', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-3.0/assets/resize-grip.svg', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-3.0/assets/scale-slider.svg', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-3.0/assets/switch-slider.svg', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-3.0/assets/pane-handle.svg', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-3.0/assets/scale-slider-insensitive.svg', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-3.0/content-view.css', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-3.0/gtk-widgets.css', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-3.0/scrollbar.css', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-3.0/menu.css', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-3.0/settings.ini', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-3.0/gtk.css', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-3.0/progressbar.css', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-3.0/toolbar.css', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-3.0/scale.css', which is also in package elementary 3.1
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/share/themes/elementary/gtk-3.0/button.css', which is also in package elementary 3.1
Setting up elementary-theme (3.4-0~r649+pkg293~precise1) ...
 

What am i doing wrong actually here ?

share|improve this question
1  
This is a bug of the package. Please report it as such. No package should try to overwrite files handles by others. –  gertvdijk Jul 21 '13 at 16:05
    
@gertvdijk This is a bug, but the question in effect asks about how to deal with a general category of bugs (packages that are not intended to conflict with each other--and thus not declared as conflicting--providing the same file). And it has a good general answer. So we should possibly keep this open, for the general element which can be considered not to be a bug report. NumanSyed: It woul still be a good thing for you to report the bug (see also this question). –  Eliah Kagan Jul 22 '13 at 6:56
add comment

1 Answer 1

The package you downloaded is conflicting with another package. You can work around this by force installing the elementary-theme package.

sudo dpkg -i --force-overwrite /var/cache/apt/archives/elementary-theme_3.4->0~r649+pkg293~precise1_all.deb

After that you might want to do a sudo apt-get upgrade to continue updating the other 45 packages.

share|improve this answer
    
Thanks for the info! But I have made it worse ! Using Synaptic Package Manager I have deleted 'elemetary-desktop' and 'elementary-xxxxxx`. However, I have tried your patch and found this: –  Numan Syed Jul 21 '13 at 17:55
    
Oops! Pressed Enter too early! –  Numan Syed Jul 21 '13 at 17:56
    
Thanks @Eliah Khan, I tried to report this when my system told me The problem cannot be reported: This is not an official Ubuntu package. Please remove any third party package and try again. Any idea on this, anybody? –  Numan Syed Jul 22 '13 at 9:45
    
I got a solution and want to put it up here but askubuntu keep telling me my answer`appears to be spam`! –  Numan Syed Jul 22 '13 at 11:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.