Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded my Ubuntu 12.04 desktop to 13.04. When it rebooted after upgrading, I noticed that it had not connected to my Wi-Fi network. When I try to connect, one of two things happen:

  1. It thinks for a second, without asking me for a password, and then pops up a notification that says that it did not connect (Says "Disconnected. You are now offline.")
  2. Or it thinks, prompts me for a password, thinks, and prompts me again. (Never-ending cycle)

I have tried multiple things, but can't seem to connect. I first thought that it might be a driver issue, but how would it find the Wi-Fi network if there was no driver?

I am hoping that someone knows what is happening and how to fix it!

Thanks,

Wasabi Fan

share|improve this question
    
Please open the terminal(ctrl+alt+t) run the commands one line at a time: lspci -nnk | grep -iA2 net lsusb iwconfig rfkill list all lsmod post the output at [link]pastebin.com [link] then post the link here. Thanks –  Wild Man Jul 21 '13 at 3:37
    
I ran the commands that you wanted, here is the output: link –  Wasabi Fan Jul 21 '13 at 20:16
    
Please try: echo "options rt2800pci nohwcrypt=1" | sudo tee /etc/modprobe.d/rt2800pci.conf sudo modprobe -rfv rt2800pci sudo modprobe -v rt2800pci If it does not connect post the output of nm-tool and sudo iwlist scan –  Wild Man Jul 21 '13 at 20:25
    
The first commands that you gave me didn't fix the problem, here is the output from the other two: pastebin.com/Z5z9dB1M –  Wasabi Fan Jul 21 '13 at 21:53
    
Please post the output of: sudo cat /var/log/syslog | grep -e rt2 -e firmware -e wlan -e wpa -e etork | tail -n45 –  Wild Man Jul 21 '13 at 22:14
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.