Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

apt-get is entirely broken for me. I have no idea how this started.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libapache2-mod-php5 : Depends: apache2.2-common but it is not going to be installed
 php5-cli : Depends: php5-common (= 5.5.0+dfsg-14ubuntu1) but 5.4.15-1ubuntu3 is to be installed
 php5-gd : Depends: phpapi-20121212
           Depends: php5-common (= 5.5.0+dfsg-14ubuntu1) but 5.4.15-1ubuntu3 is to be installed
 php5-mcrypt : Depends: phpapi-20121212
 php5-mysql : Depends: phpapi-20121212
              Depends: php5-common (= 5.5.0+dfsg-15ubuntu1) but 5.4.15-1ubuntu3 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

sudo apt-get -f install does not work and sudo apt-get --fix-missing install does not work either.

output of sudo apt-get -f install

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
Use 'apt-get autoremove' to remove it.
The following extra packages will be installed:
  libapache2-mod-php5 php5-cli php5-common php5-gd
Suggested packages:
  php-pear php5-json php5-user-cache
The following packages will be upgraded:
  libapache2-mod-php5 php5-cli php5-common php5-gd
4 upgraded, 0 newly installed, 0 to remove and 53 not upgraded.
6 not fully installed or removed.
Need to get 0 B/5,945 kB of archives.
After this operation, 229 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
WARNING: The following packages cannot be authenticated!
  libapache2-mod-php5 php5-cli php5-gd php5-common
Install these packages without verification [y/N]? y
Setting up apache2 (2.4.4-6ubuntu4) ...
 * Starting web server apache2                                           [fail] 
The apache2 configtest failed. Please run 'env -i LANG=C PATH=/usr/local/bin:/usr/bin:/bin /usr/sbin/apache2ctl configtest' manually and read the log file to discover problems
invoke-rc.d: initscript apache2, action "start" failed.
dpkg: error processing apache2 (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
share|improve this question
Please provide the output of sudo apt-get -f install. "does not work" isn't very descriptive. Also explain how you get the 5.5 version of PHP there. Did you add a PPA or other repository? Include which exactly. This repository breaks APT on your installation. Edit your question to include all this information. –  gertvdijk Jul 20 '13 at 23:25
Until you provide even more information, we can't do anything better than refer you to How do I resolve unmet dependencies?. Please note, far more than the 2 solutions you've told us about trying are presented, so even if you were referring to that question when you said "usual solution," it's unclear which other solution(s) you've tried, if any. Please edit your question to tell us about all the possible solutions you've tried and exactly what happened for each. We may close this as a duplicate but even if so it may be reopened if you provide more details. –  Eliah Kagan Jul 20 '13 at 23:51
I have added the output. –  Cary Hartline Jul 23 '13 at 3:43
add comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.