Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Whenever I connect an external display to the DSub port of my laptop before booting into Ubuntu, something goes wrong in Unity to cause the exact same problem as described here: After logging in, there's a black screen and my cursor, nothing else! in Ubuntu 12.10 Rebooting without the display connected does not fix it.

A once-off fix is to do this:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:unity-team/staging

sudo apt-get update
sudo apt-get install --reinstall ubuntu-desktop
sudo apt-get install unity

or, much quicker, this:

unity --reset
sudo service lightdm restart

Side effect of this solution: I lose all of my Unity appearance settings.

My problem, however, is that I need to boot with the external display connected quite often. Who knows what goes wrong inside Unity and/or how to fix it permanently?

share|improve this question
    
It might help to know what hardware you are using. Some laptops have a BIOS setting to enable/disable external. –  Elder Geek Jan 7 at 2:12
    
I checked... No such settings in my BIOS. At least not with the current (factory) firmware. HP ProBook 6560b –  rudolfbyker Feb 11 at 21:19

2 Answers 2

You could create a script to run at startup that uses your quickest workaround, I.E.

unity --reset
sudo service lightdm restart

This shouldn't have any negative consequences if the external isn't connected and should resolve the problem if it is....

Source: Question

share|improve this answer
    
Side effect of this solution: I lose all of my Unity appearance settings when the script runs. –  rudolfbyker Feb 11 at 21:18
    
Added that missing information to your question. –  Elder Geek Feb 11 at 21:35
    
It's very obvious from man unity: --reset This option allows the user to reset profile parameters in compiz and restart the Unity shell with default settings. –  rudolfbyker Feb 11 at 21:38
    
This is true, but what's not obvious is that you changed your Unity appearance settings from the defaults. I felt that information was useful. –  Elder Geek Feb 11 at 21:42
    
Have you tried simply sudo service lightdm restart ? –  Elder Geek Feb 11 at 21:46

I've received this black screen with cursor myself (I use 4 monitors, and so unplugging them happens often).

However my fix was to correctly install my GPU's drivers.

Since your laptop apparently has an Intel HD 3000 series GPU have you tried installing up-to-date drivers? The Additional Drivers tab in your Software & Updates part of System Settings would be a good place to start.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.