Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In the terminal, whenever I try to perform sudo, Ubuntu asks my password and it always says I typed it in wrong.

I tried changing the password as root, but then it says password unchanged.

My user don't have to enter its password on the login screen, and I think that may have something to do with it.

Does anyone know how to fix this?

share|improve this question

2 Answers 2

up vote 2 down vote accepted
  • Boot in recovery mode as root

perform these commands:

  • mount -o rw,remount /
  • nano /etc/sudoers

Look for a line containing root ALL=(ALL:ALL) ALL, below that add this line:

your_username_here ALL=(ALL:ALL) ALL

(change your_username_here to your actual username)

(Press Ctrl+X to exit nano, and answer 'y' to save the changes)

  • Enter passwd your_username_here and set a new password.

(change your_username_here to your actual username)

  • Reboot

(source)

share|improve this answer
    
thank you so much it all worked perfectly. :) –  Paindeer Jul 21 '13 at 0:31

Assuming you have the right password, double check your caps-lock and num-lock keys. Those can mess up your password.

share|improve this answer
    
I have no caps lock on or num lock, but I did make it so my user doesn't have to enter their password and I think that may have something to do with it. –  Paindeer Jul 20 '13 at 19:08
    
@Paindeer this information is important, I have suggested an edit to include it –  That Brazilian Guy Jul 20 '13 at 20:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.