Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have researched this and tried the suggested solutions and haven't been able to fix it in my case.

I have a Dell Inspriron 15 R SE.

It came pre-loaded with Windows 8. I booted into the BIOS and turned off EFI security and installed Windows 7 and I'm now trying to install Ubuntu in a dual boot situation.

When I run the installer it tells me there is no OS installed but, when I read up on this it says that you can run sudo os-prober or sudo WINOSDATA=true os-prober.

It finds my Windows 7 installation. However when I run WINOSDATA=true ubiquity, I still get the message saying there is no OS installed.

I have split my 1TB drive putting aside a ext4 partition (about 350 gb) and a linux-swap partition (5 gb) for the installation, but it's only picking up the whole 1TB drive and not the two partitions I created and of course it doesn't see the windows installation.

edit: I have also ran gparted when booted into the live cd. It only sees my HD as one big 1TB partition. It does not see the swap partition or the ext4 partition I created nor does it mention anything about windows being installed

What else can I do to get Ubuntu installed? Thanks in advance!

share|improve this question
add comment

1 Answer

I have never done this, but it may work.

When you boot with LiveCD, Click on the Software Centre icon and search for gparted.

When it is installed, run it by clicking the icon on the launcher and see what it shows there. If it shows the Windows partition and your partitions, all well and good, there is a problem with the installer. However, if it doesn't, Create your partitions here and start again.

There is a real problem with installing over Windows8 and to check that you have not missed anything, check here

share|improve this answer
    
I tried gparted and it only shows one partition with the full 1TB. It's not detecting the ext4 partition, the linux swap partition or the windows partition. Windows has been working without any problems though. I really don't want to have to reformat my entire HD and start over. –  user176822 Jul 20 '13 at 16:37
    
I'm afraid that I do not have a PC that has had Windows 8 on it. All I can suggest is follow the link in the answer I gave help.ubuntu.com/community/WindowsDualBoot which may point you in the right direction. –  SimplySimon Jul 20 '13 at 16:42
    
Thanks for the input. Yeah nothing in that really helped me. I've installed unbuntu a thousand times but never came across this. I really don't want to have to reformat my computer just to run ubuntu. I really shouldn't have to. I just don't understand why it's not seeing the windows installation –  user176822 Jul 22 '13 at 13:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.