Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed 12.04 onto this little Sony, taking everything but the small recovery partition for its original Vista OS, and everything went well.

Yesterday, I noticed when I turned it on, the screen was blank on the right, with vertical lines on the left - the colors of the vertical lines match the logon screen, during boot-up, but then the logon screen appeared, I entered my password, and everything worked well.

I installed Dropbox, synced it with my other 12.04 machine, then installed dropbox, and synced it. At this point, the battery was starting to get low, so I placed the sony onto it's docking port, where the power cord was plugged in, and the screen went blank on the left, with vertical lines on the right.

As I couldn't get the machine to do anything, and was therefore unable to shutdown properly, so I removed it from the docking platform, to let the battery run down, as I have it set to shut down due to low battery.

This morning, I energized the machine, and found the same issue.

  • I have tried starting on the battery, with the plugged in docking port, with the power cord plugged directly into the computer, and each of the previous methods with the battery removed, to no avail.
  • I have tried to get into the bios with the FN + F1, F2, F3 and F4 with no joy.
  • I tried powering on while pressing ESC - no joy.
  • I read something to do with video speed/stamina switch, which sounded like a physical switch, but have been unable to find anything specific to this computer.

I am hoping that some of you who are smarter than me, may have the answer. Thanks for reading, and thanks for any insight you may be able to provide. -Chris

share|improve this question

1 Answer 1

I have recently ditched my Sony Vaio, however I had fun using it With Ubuntu. The problem you are experiencing is due to the Graphics Driver.

Firstly, start the computer and at the GRUB menu, click the down key until you select advanced mode, or something like that. continue to load Ubuntu with the default drivers, I'm sorry but I don't remember the exact menu items. then...

...because the Graphics Card you have is probably a Nvidia one, what you need to do is to open System Settings and then click on Software and Updates. Go to the Additional Drivers tab and click on it. From the list of alternative drivers, select one that is not selected, I'd try to run with the highest spec first and work my way down until I found something that worked.

I hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.