Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I think I've messed up something with my partition mount points.


OK, this is the thing. When I have been fresh installing Ubuntu 12.10 from a Live CD, I made all my partitions with ext4 file system format and mounted them at random mount points (now special interest on /DOS and /Windows, see it here). After installation complete, I wasn't happy without seeing my partitions appear as shown in a picture at the red "A". As I had them there on my previous older laptop, witch was dual boot alongside with WimXP, and these partitions were NTFS. So I decided to format them back to NTFS. I've labeled these HDD1 and And HDD2. And somehow it become mounted an the directory /mnt/33E6E20A00342E2D and /mt/486FFA615D0979A2 seen in this picture at "B" and "C" marks. Despites all that, in general it worked all fine. Until I boot the machine next time, I encountered with the problem explaned here: "How to avoid "S to skip" message on boot?". I did try all the mentioned solutions and none worked in my case. As in my case there in no longer any partition as /DOS and /Windows.
Now from here: "Specifying a custom mount point for an empty partition", I found that it may be the better way of having my partitions in a place "A" in this picture. I am willing to reformat these partitions back again to ext4, and mount them in a folder as /example/HDD1 and /example/HDD2 so I easy and quick access when needed. But I get now very confused what to do next.

Should I use Disks or GParted? And what should I do with my "S to skip"? I can't just delete these directories.


Bonus:

! Picture with "A,B,C"
! Picture with 2 Folders Selected (Containing a total of 0 items)
! Picture with Disks-sda1 selected (HDD1, /windows before)
! Picture with Disks-sda5 selected (HDD2, /dos before)
! Picture with GParted
! Can't delete folder (directory with 0 items)


Edit 1

I have just deleted the directories using Nautilus as root. Here is the process outcome:

gedis@gedis-A8J:~$ sudo su 
[sudo] password for gedis: 
root@gedis-A8J:/home/gedis# nautilus 
Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory 
Please ask your system administrator to enable user sharing. 


** (nautilus:24006): WARNING **: Could not inhibit power management: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Name "org.gnome.SessionManager" does not exist 

** (nautilus:24006): WARNING **: Could not inhibit power management: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Name "org.gnome.SessionManager" does not exist 
root@gedis-A8J:/home/gedis# exit 
exit 
/bin/rm: cannot remove `/run/user/root/gvfs': Is a directory 
gedis@gedis-A8J:~$ 

After rebooting the problem "press S to skip" is still here. Will try now updating the Grub2


Edit 2

Just updated the Grub2. This is the process outcome:

gedis@gedis-A8J:~$ sudo su
[sudo] password for gedis: 
root@gedis-A8J:/home/gedis# gksu update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.5.0-36-generic
Found initrd image: /boot/initrd.img-3.5.0-36-generic
Found linux image: /boot/vmlinuz-3.5.0-34-generic
Found initrd image: /boot/initrd.img-3.5.0-34-generic
Found linux image: /boot/vmlinuz-3.5.0-17-generic
Found initrd image: /boot/initrd.img-3.5.0-17-generic
Found memtest86+ image: /boot/memtest86+.bin
done
root@gedis-A8J:/home/gedis# exit
exit
gedis@gedis-A8J:~$ exit

After rebooting the problem "press S to skip" is still here...

How can I fix this?

share|improve this question
1  
You may need to be root before you delete Windows. launch nautilus (the file Manager) wuth sudo nautilus from terminal. –  SimplySimon Jul 20 '13 at 14:03
    
Just a little thing more, if I just delete the folder /dos and /windows will solve all my "press S to skip" problem while booting? –  Gediminas Jeremiah Gudelis Jul 21 '13 at 14:54
    
The Grub programme looks for a boot loader, so you need to find the windows boot partition, and delete that. I believe it's about 50Mb in size. This will stop Grub from seeing the Windows installation. The other way is to download Grub Customizer from the Programme Manager and have a play :) –  SimplySimon Jul 21 '13 at 16:29
1  
Grub is easily broken. by all means follow some instructions, but be very careful. –  SimplySimon Jul 23 '13 at 7:37
1  
Have you edited your /etc/fstab? If not, simply remove the unnecessary entries. –  meskobalazs Jul 24 '13 at 15:45
show 4 more comments

2 Answers

up vote 2 down vote accepted

Your link shows how to edit fstab. You have the entries (/dos and /windows) in fstab and that is why it is trying to mount those entries on reboot.

Check fstab and make sure you specify the same format in the fstab entry as partition is formatted. If not running Windows better to use ext4, but to use partition you will also need to set ownership & permissions to easily use partition as a data partition.

Anytime you edit fstab, run this command to make sure all entries are valid. It will remount and give no errors if correct:

sudo mount -a

share|improve this answer
    
As I understood, when editing /etc/fstab with Gedit I can just add "#" at the beginning of these lines were the Mount Point is /dos and /windows (as the directories as such do not exist anyway)? –  Gediminas Jeremiah Gudelis Jul 24 '13 at 17:50
add comment

If you download Grub Customizer from the Software Centre, when you run the programme, you can edit the following on the General Settings tab.:

Grub Customizer

  • Un-check the look for other operating systems.
  • Set the Timeout to 0 Seconds
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.