Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Ubuntu 13.04 OS and when I install Google Chrome and Firefox and open Facebook for the first 2 days it works perfect, and suddenly some images don't appear like my friends profile pictures or shared photos while others appear, this is a print screen.

enter image description here

This problem occurs with facebook only.

How can I solve it?

share|improve this question
    
Have you tried clearing the cache of your browser? Also try to press Shift + F5 to force reload all the contents. Another problem might be DNS issues - try using a different DNS (Google or OpenDNS) - see this question on how to do that - What is the proper way to change the DNS IP? –  Aditya Jul 20 '13 at 14:44
add comment

2 Answers 2

Go to Account Settings > Security Settings > Secure Browsing and uncheck this option: "Browse Facebook on a secure connection (https) when possible". Then save changes and refresh Facebook.

share|improve this answer
    
Apparently I'm the only person in the world that doesn't have the secure browsing option in my FB account settings. Any other solutions to this problem? –  Debbie Apr 10 at 15:36
add comment

Edit your network connection settings, and change the DNS servers to point to Google's public DNS servers:

8.8.8.8
8.8.4.4
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.