Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Seagate 500 GB external HDD stopped working few days ago for unknown reasons. I don't really care about the data on it anymore. I just want it to work properly again but I cant format it in Gparted or Disk Utility. In fact, I can't even see my drive in both places. I get this error when I connect it via USB:

Error mounting /dev/sdb1 at /media/sourabh/Backup: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sdb1" "/media/sourabh/Backup"' exited with non-zero exit status 13: The disk contains an unclean file system (0, 0).

The file system wasn't safely closed on Windows. Fixing. ntfs_attr_pread_i: ntfs_pread failed: Input/output error Failed to read NTFS $Bitmap: Input/output error NTFS is either inconsistent, or there is a hardware fault, or it's a SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows then reboot into Windows twice. The usage of the /f parameter is very important! If the device is a SoftRAID/FakeRAID then first activate it and mount a different device under the /dev/mapper/ directory, (e.g. /dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation for more details.

Failed to sync device /dev/sdb1: Input/output error

Failed to close volume /dev/sdb1: Input/output error

How can I force format this drive?

share|improve this question
    
"In the first case run chkdsk /f on Windows then reboot into Windows twice". You need to fix the errors on the disc from within Windows before you can mount it. –  Rinzwind Jul 20 '13 at 6:50
    
I did try that, as advised on some other forum, but it didn't work. Ubuntu Disks says Reallocated Sector Count: failing. –  Sourabh Jul 20 '13 at 7:35
add comment

1 Answer

force the format on windows via Disc manager, or however they call it now in your windoze version. This should work as well. If you prefer The Linux way, then you can list your drives by

fdisk -l | grep '^Disk'

choose which you want to re-partition and create partitions by

fdisk /dev/sdx

where you replace x for letter of your drive. Use "m" for list the fdisk help and then follow the white rabbit. Do not make a mistake in choosing your drive, you can easily kill any other drive and data.

share|improve this answer
    
fdisk -l | grep '^Disk' does nothing. –  Sourabh Jul 20 '13 at 10:56
    
@ Sourabh: should be a shortened list of fdisk -l where only the lines beginning "Disk" are listed, so try it without grep. Search for line looking like Disk /dev/sda: 640.1 GB, 640135028736 bytes , maybe your localization calls disk differently... –  Dee Jul 21 '13 at 20:09
    
Yes I even tried fdisk -l but it didn't do anything either. I even tried seatools software but even that was unable to detect my drive. I guess my drive's really dead –  Sourabh Jul 22 '13 at 8:05
    
Yes, it is possible... check the cables, small chance, but most common reason... do the Bios see the harddisk? –  Dee Jul 22 '13 at 12:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.